This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 407061 - Software Manager Crash on Newly Installed System
Software Manager Crash on Newly Installed System
Status: CLOSED DUPLICATE of bug 378911
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 19:35 EST by Kuang-Yu Liu
Modified: 2007-12-04 10:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 10:45:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kuang-Yu Liu 2007-11-30 19:35:55 EST
Component: Software Manager
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError:
local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 334, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 557, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 322, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in
downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 461, in getHeader
    cache=cache,
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote:
https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5/getPackage/kdeartwork-3.5.4-1.fc6.x86_64.rpm
start: 440
url: None
text: None
self: rhel-x86_64-server-5
cache: True
reget: None
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5
relative: getPackage/kdeartwork-3.5.4-1.fc6.x86_64.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''),
('X-RHN-Auth', 'icaqJhYoSpY1IGrLBQ/8wQ=='), ('X-RHN-Auth-Server-Time',
'1196467853.25'), ('X-RHN-Server-Id', 1008496313))
checkfunc: (<bound method PackageManager.verifyHeader of
<__main__.PackageManager object at 0x37871d0>>,
(<yum.sqlitesack.YumAvailablePackageSqlite instance at 0x491ccf8>, 1), {})
copy_local: 1
end: 69792
local:
//var/cache/yum/rhel-x86_64-server-5/headers/kdeartwork-3.5.4-1.fc6.x86_64.hdr
Comment 1 Justin Sherrill 2007-12-04 10:45:35 EST

*** This bug has been marked as a duplicate of 378911 ***

Note You need to log in before you can comment on or make changes to this bug.