Bug 407411 - Doesn't work..
Doesn't work..
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: isomaster (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Marcin Zajaczkowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 12:06 EST by Bob Gustafson
Modified: 2007-12-02 07:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-02 07:45:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2007-12-01 12:06:57 EST
Description of problem:

  I click on icon/name of an iso file in the gnome panel, and nothing happens.

Version-Release number of selected component (if applicable):

  isomaster 1.1

How reproducible:

  always (for me)

Steps to Reproduce:
1. Applications -> Accessories -> ISO Master
2. Navigate to a directory containing iso files
3. Click on icon/name of iso file
4. Nothing happens.
  
Actual results:

  As above - nada, zit

Expected results:

  As documentation states, the lower part of the panel should fill with the
icon/names of directories/files within the iso file.

Additional info:

Currently using Fedora 7. Would like to use Fedora 8, but am facing the
f8upgdephang bug. Was hoping that ISO Master would help create a new F8.iso
Comment 1 Marcin Zajaczkowski 2007-12-01 14:06:45 EST
I can't reproduce that. 
1. Could you start isomaster from a console to see for displayed errors?
2. Is it some specified ISO image? I yes, please check with some other images
too.  And if it is possible please provide a path to that calamitous iso.
Comment 2 Bob Gustafson 2007-12-01 14:35:28 EST
1.

[root@hoho2 sql]# isomaster
ISO Master warning: failed to open config file for reading, trying to create

[root@hoho2 sql]# 

-----

When I try as a user, I get:

[user1@hoho2 ~]$ isomaster

[user1@hoho2 ~]$ 

No messages

----

Looking for config file

[user1@hoho2 ~]$ ls -la | grep master
-rw-r--r--  1 user1 user1      619 2007-12-01 11:02 .isomaster
[user1@hoho2 ~]$

----
Contents of config file:

[user1@hoho2 ~]$ cat .isomaster

[ui]
windowwidth                    = 787
windowheight                   = 804
toppaneheight                  = 321
fscurrentdir                   = /home/user1/Desktop/FC6/
showhiddenfilesfs              = 0
sortdirsfirst                  = 1
scanforduplicatefiles          = 1
followsymlinks                 = 0
appendextension                = 1
editor                         = text-editor.sh
viewer                         = xdg-open
tempdir                        = /tmp
isosortcolumnid                = 1
isosortdirection               = 0
fssortcolumnid                 = 1
fssortdirection                = 0

[user1@hoho2 ~]$ 

Hope this helps

2.

I tried several, thinking it might be size related, I tried smaller isos.
Comment 3 Bob Gustafson 2007-12-01 14:46:22 EST
When I do:

[user1@hoho2 FC6]$ xdg-open FC-6-i386-disc1.iso

I get a dialog panel that is titled "Write to Disk"
My DVD/CD burner is the choice on one of the popups.

At least xdg-open exists on my system..
Comment 4 Marcin Zajaczkowski 2007-12-01 15:30:16 EST
I think I know what the problem is.
To open ISO file you should use Image->Open (from a menu), not double click on
that file.
Could you try it?
Comment 5 Bob Gustafson 2007-12-01 17:47:01 EST
I select an iso file in the top pane.

I go to Image->Open

and

It opens up a directory viewer in a separate window with the title 'Open File'
and the left pane shows 'user1' highlighted (my username) and the directories
(no files) listed in the right pane are from my own disk directory.

No iso files in the lower pane of ISO Master...
Comment 6 Bob Gustafson 2007-12-02 07:36:28 EST
OK, figured it out.

In comment #5 above (the new window), when I navigate to my iso file in that
window, and then double-click on an iso file, then the lower panel of the
original dialog fills in with the files/directories in the iso file.

Weird. Why have the 2nd window popping up? What good is the top pane in the
original user interface?

Certainly not an 'intuitive' GUI.

But, it does seem to work. Thanks much.
Comment 7 Marcin Zajaczkowski 2007-12-02 07:45:17 EST
I already reported your suggestion to the author about automatically opening ISO
when double clicked on them (in the upper pane). The list above is used for
adding files when some iso is already opened. In fact it could be a little bit
confusing after fresh start.

Note You need to log in before you can comment on or make changes to this bug.