Bug 407421 - keyboard locks to last state at random times.
keyboard locks to last state at random times.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 12:12 EST by Axel Thimm
Modified: 2008-03-16 05:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-16 05:52:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2007-12-01 12:12:49 EST
Description of problem:
I recently upgraded an updated F7/x86_64 system to F8 + updates. Since then I
get 3-4 times a day a hanging keyboard. No input makes it to the system either X
or console and no keyboard lights work. Rebooting the system (by mouse pointer
or remotely) or suspending/resuming it reactivates the keyboard. Dropping out of
X11 to initlevels 3 or 1 is not enough.

Version-Release number of selected component (if applicable):
2.6.23.1-49.fc8

How reproducible:
About every 60-120 minutes working on the keyboard makes it disconnect.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The MB is an Asus A8V-E Deluxe, and the system worked fine with F7's latest
kernel, 2.6.23.1-21.fc7. I can't definitely nail the kernel to this bug, but
since killing X11 and dropping down to the console or even single user mode
doesn't fix it it looks like it.
Comment 1 Axel Thimm 2007-12-04 16:31:29 EST
Some more info: When that happens it can also "remember" the last key pressed
and repeat it forever. E.g. the keyboard is either dead or locked on one key
press. Either way it is in this frozen state until one does a suspend/resume action.
Comment 2 Kent Engström 2008-01-08 04:05:34 EST
I think I am hit by the same bug, on a Compaq nc6400 laptop.
The keyboard gets stuck repeating the last key.
Sometimes I am able to get it out of that, sometimes not.
Restarting X does not help.

No problems when I was running FC6. The problems started after upgrading
to F8, but I did not notice at first as I was using a USB keyboard
(no problems with that one).

Seen on both 2.6.23.1-49.fc8 and 2.6.23.9-85.fc8.
Comment 3 Axel Thimm 2008-01-08 14:14:08 EST
It has happened on all F8 kernels so far, since my upgrade to F8 from F7. I'm
suspending/resuming the system about 10-15 times a day :(

I think it may correlate to swapping in/out times or in general IDE activity.
Comment 4 Chuck Ebbert 2008-01-09 14:56:33 EST
Are there any messages appearing in the system log when this happens?
Comment 5 Kent Engström 2008-01-14 09:39:42 EST
For me: no.
Comment 6 Kent Engström 2008-01-14 09:49:43 EST
I have now borrowed another nc6400 laptop from the hardware guys at work
and will swap disks and try that one, to rule out hardware problems.
Comment 7 Axel Thimm 2008-03-16 05:52:52 EDT
Since a couple of kernel rpm releases I don't see this bug anymore. I guess it
was fixed upstream, so I'm closing as such.

Note You need to log in before you can comment on or make changes to this bug.