Bug 40749 - anaconda chrashes while installing image
Summary: anaconda chrashes while installing image
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-15 16:44 UTC by meggis
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 14:26:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description meggis 2001-05-15 16:44:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; QXW03336)

Description of problem:


How reproducible:
Always

Steps to Reproduce:
1. Try to install
2.
3.
	

Actual Results:  It works all fine till installing the image. Seems, that 
anaconda tries to unmount something (probably /mnt/source) and stops with 
a failure.

Traceback:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1782, in 
doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 632, in 
umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  
File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys
.py", line 134, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

After stopping anacondo following messages appear:
unmounting filesystems ...
  /mnt/sysimage
  /mnt/runtime
  /mnt/source unmount failed ()
  /dev/pts
  /proc
you may safely reboot your system

Additional info:
It4s impossible for me to install redhat 7.1

Comment 1 Brent Fox 2001-05-15 18:16:04 UTC
Did you try setting a mount point for a DOS partition?  If so, try doing the
install again without setting a mount point for any DOS partitions.  You can add
them later to the /etc/fstab file.  Does this help?

Comment 2 meggis 2001-05-15 19:52:13 UTC
bfox: yes i4ve tried this. i4ve got some more details now. this error only 
comes up, if i customize the installation (sources).
if i customize installation without selecting kernel-development installing 
works. if i customize installation without selecting kernel-development , but 
selecting single packages (dev-packages and normal) anaconda crashes again with 
the same error.


Comment 3 Brent Fox 2001-05-16 20:00:52 UTC
What partitions did you make and how big are they?

Comment 4 Brent Fox 2001-05-16 20:06:10 UTC
Looks like a dupe of bug #38448

Comment 5 meggis 2001-05-17 06:57:23 UTC
yes i think it4s nearly the same problem as in bug #38448, but my customized 
installation also crashes if i don4t set a mount point for the DOS partition. I 
think there must be a problem with selecting and deselecting single packages.

partition data:
/dev/hda1 DOS    1.5 GB
/dev/hda2 linux  2.5 GB used as /
/dev/hda5 swap   128 MB

Now I4ve installed RedHat using customized installation, selecting the main 
packages (not servers and kernel-development) and afterwards customize it using 
the packagemanager. I4m not satisfied with this, but it works :-)

Comment 6 Brent Fox 2001-05-17 21:25:03 UTC
That's strange because I tested the individual package selection screen pretty
thoroughly.  So selecting dev-packages causes the installer to crash for you?

Comment 7 Brent Fox 2001-05-29 14:26:43 UTC
Closing due to inactivity. Please reopen if you have more information.


Note You need to log in before you can comment on or make changes to this bug.