Bug 407651 - SELinux is preventing /bin/dbus-daemon (xdm_t) "bind" to (xdm_t).
SELinux is preventing /bin/dbus-daemon (xdm_t) "bind" to (xdm_t).
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 23:44 EST by Jim Cornette
Modified: 2007-12-05 23:19 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 23:19:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2007-12-01 23:44:28 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Boot with kernel-2.6.23.1-49.fc8 with SELinux in permissive, using gdm as
display manager to start GNOME.

Steps to Reproduce:
1. boot with enforcing=0
2. Click on user and enter password in gdm
3. Open troubleshooter browser and evaluate errors.
  
Actual results:
Errors in SELinux troubleshooter browser

Expected results:

Expected some since user environment for gdm changed from previous nd other
testers are going back to older versions of gdm.
Summary
    SELinux is preventing /bin/dbus-daemon (xdm_t) "bind" to <Unknown> (xdm_t).

Detailed Description
    SELinux denied access requested by /bin/dbus-daemon. It is not expected that
    this access is required by /bin/dbus-daemon and this access may signal an
    intrusion attempt. It is also possible that the specific version or
    configuration of the application is causing it to require additional access.

Allowing Access
    You can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 Or you can disable
    SELinux protection altogether. Disabling SELinux protection is not
    recommended. Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi
    against this package.

Additional Information        

Source Context                system_u:system_r:xdm_t:SystemLow-SystemHigh
Target Context                system_u:system_r:xdm_t:SystemLow-SystemHigh
Target Objects                None [ netlink_selinux_socket ]
Affected RPM Packages         dbus-1.1.2-9.fc9 [application]
Policy RPM                    selinux-policy-3.1.2-2.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   plugins.catchall
Host Name                     HP-JCF7
Platform                      Linux HP-JCF7 2.6.23.1-49.fc8 #1 SMP Thu Nov 8
                              21:41:26 EST 2007 i686 athlon
Alert Count                   1
First Seen                    Sat 01 Dec 2007 11:02:16 PM EST
Last Seen                     Sat 01 Dec 2007 11:02:16 PM EST
Local ID                      f0d23df2-f392-4ae6-9b0a-0616645b5b71
Line Numbers                  

Raw Audit Messages            

avc: denied { bind } for comm=dbus-daemon egid=42 euid=42 exe=/bin/dbus-daemon
exit=0 fsgid=42 fsuid=42 gid=42 items=0 pid=2426
scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 sgid=42
subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 suid=42
tclass=netlink_selinux_socket tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tty=(none) uid=42


Additional info:
Comment 1 Jim Cornette 2007-12-05 23:19:48 EST
Closing bug since it appears all (xdm_t) related errors have been fixed at present. 

Note You need to log in before you can comment on or make changes to this bug.