Bug 407721 - rt61pci constant timeout when connecting to AP using WPA
rt61pci constant timeout when connecting to AP using WPA
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 04:04 EST by David Nielsen
Modified: 2007-12-05 14:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 14:04:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2007-12-02 04:04:42 EST
Description of problem:
using kernel-2.6.24-0.62.rc3.git5.fc9 I can no longer connect to my router when
WPA is enabled, standard unencrypted works fine though. This last worked when
using kernel-2.6.24-0.57.rc3.git4.fc9 so the "Some wireless bits headed for
2.6.25" change which seems to be the only thing that could affect this which was
also pushed to a F8 test kernel seems broken. This might be considered a blocker
for that update potentially.

Version-Release number of selected component (if applicable):
kernel-2.6.24-0.62.rc3.git5.fc9

How reproducible:
100%

Steps to Reproduce:
1. install kernel-2.6.24-0.62.rc3.git5.fc9
2. reboot
  
Actual results:
no WPA connections possible

Expected results:
Glorious WPA network

Additional info:
Comment 1 John W. Linville 2007-12-02 17:50:22 EST
Did you happen to try 2.6.24-0.59.rc3.git5.fc8?  It isn't clear to me if you 
tried the kernels in between 2.6.24-0.57.rc3.git4.fc9 and 
2.6.24-0.62.rc3.git5.fc9.

Does 0.59 work any better?  Just trying to narrow things down...
Comment 2 David Nielsen 2007-12-03 09:47:46 EST
I did not try anything in between the two, however now it started happening with
kernel-2.6.24-0.57.rc3.git4.fc9 as well which worked previously. This is
starting to get scary, it was flawless yesterday. Boot into the old kernel and
it worked just like it had on that kernel since it was released, boot into the
other one and there was no WPA.. I turn on the machine this morning and now
there's no WPA on either one. 

I'm stomped as to what could cause this, I was so sure it was the wifi update.
Comment 3 John W. Linville 2007-12-03 10:27:41 EST
I've been seeing some complaints about newer versions of NM not working w/ WPA 
(beats me)...is it possible that either NM or wpa_supplicant got upgraded 
along the way?
Comment 4 Dan Williams 2007-12-03 10:39:10 EST
Best thing to do to debug issues like this is to create a wpa_supplicant config
and fire up wpa_supplicant by itself.  There have been some wpa_supplicant
updates in recent history, but nothing core to the behavior of association at
all.  Usually doing a plain wpa_supplicant run will isolate whether the issue is
driver/stack or userland pretty quickly.
Comment 5 David Nielsen 2007-12-03 12:44:12 EST
With my QA hat on. Dan do we have a guide to doing that? It would be helpful to
add to the bug triaging page.

According to Koji there has been no NM update since the 27th of November, and no
wpa_supplicant update since the 13th of November. Since I've only been seeing
this the past few days I am wondering what could have caused it, there was a
dhcp update yesteday I think but that is all I recall even remotely networking
related.
Comment 6 David Nielsen 2007-12-05 14:04:31 EST
Due to the strangeness of this error I decided to reset the router and now WPA
is back, I'll file a bug with the vendor since this appears to be their error.

Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.