Bug 407811 - No sound for non-priviledged users
No sound for non-priviledged users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-12-02 08:45 EST by Nicolas Mailhot
Modified: 2007-12-05 13:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 13:22:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2007-12-02 08:45:48 EST
As a normal user in fedora devel I have no sound in apps

Running pulseaudio manually I see it complains of me lacking rt priviledges, and
asks me to add myself to pulse-rt group or perform some policykit magic

I added myself to the pulse-rt group, and got sound, but normal users should not
have to bother about it. Please automate sound priviledges granting for dekstop
users

pulseaudio-0.9.8-4.fc9.x86_64
Comment 1 Lennart Poettering 2007-12-04 02:41:18 EST
Hmm? PA does not require RT scheduling priviliges. If you enabled RT sched in
the configuration, then you also should make sure to allow PA to actually enable
it. 

However, by default PA does not use RT scheduling and works without any special
privileges.

If it didn't work that way for you, than you hit some other bug.

I am closing this bug now as NOTABUG. Feel free to file another bug, if you have
trouble to use PA without RT scheduling. 
Comment 2 Nicolas Mailhot 2007-12-04 03:46:29 EST
Since I've done *zero* pulseaudio customization on my setup right now (I only
looked at it because my desktop suddenly lost sound), that means whatever
offending config setting has been shipped in rawhide and will hit others
Comment 3 Nicolas Mailhot 2007-12-05 13:22:49 EST
seems to have went away with latest rawhide sync

Note You need to log in before you can comment on or make changes to this bug.