Bug 407821 - Evolution died when running yum update
Evolution died when running yum update
Status: CLOSED DUPLICATE of bug 427348
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 09:12 EST by Kjartan Maraas
Modified: 2008-01-06 11:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 11:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2007-12-02 09:12:20 EST
Description of problem:

Evolution crashed on me while yum was updating it from rawhide. I got this in my
~/.xsession-errors:

evolution: xcb_lock.c:77: _XGetXCBBuffer: Forutsetningen (assertion) «((int)
((xcb_req) - (dpy->request)) >= 0)» feilet.
Loading Spamassasin as the default junk plugin
creating
fff
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x22d1777]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0x22d183e]
#2 /usr/lib/libX11.so.6 [0x44a168]
#3 /usr/lib/libX11.so.6(XUngrabPointer+0x25) [0x4408e5]
#4 /usr/lib/libgdk-x11-2.0.so.0(gdk_display_pointer_ungrab+0xdc) [0xf550c1]
#5 /usr/lib/libgdk-x11-2.0.so.0(gdk_pointer_ungrab+0x1c) [0xf2b0f2]
#6 /usr/lib/gtk-2.0/modules/libgnomebreakpad.so [0x4b7945e]
#7
/usr/lib/gtk-2.0/modules/libgnomebreakpad.so(_ZN15google_breakpad16ExceptionHandler21InternalWriteMinidumpEijPP10sigcontext+0x43)
[0x4b79b73]
#8
/usr/lib/gtk-2.0/modules/libgnomebreakpad.so(_ZN15google_breakpad16ExceptionHandler15HandleExceptionEi+0x9e)
[0x4b7a08e]
#9 [0x12d420]
#10 /lib/libc.so.6(abort+0x101) [0x622ff91]
#11 /lib/libc.so.6(__assert_fail+0xee) [0x622793e]
#12 /usr/lib/libX11.so.6 [0x449f74]
#13 /usr/lib/libX11.so.6 [0x44a14d]
#14 /usr/lib/libX11.so.6(_XReply+0x142) [0x44b172]
#15 /usr/lib/libX11.so.6(XGetWindowProperty+0x96) [0x4296c6]
#16 /usr/lib/libgdk-x11-2.0.so.0 [0xf6974f]
#17 /usr/lib/libgdk-x11-2.0.so.0 [0xf697f8]
#18 /usr/lib/libgdk-x11-2.0.so.0 [0xf697f8]
#19 /usr/lib/libgdk-x11-2.0.so.0(gdk_screen_broadcast_client_message+0x154)
[0xf699e5]
evolution: xcb_xlib.c:73: xcb_xlib_lock: Forutsetningen (assertion)
«!c->xlib.lock» feilet.

I've seen a lot of hangs in evolution earlier while running yum update from
rawhide and those have not necessarily been while updating evolution itself. The
backtraces from those also originated in libxcb so I thought I'd mention them here:

http://bugzilla.gnome.org/show_bug.cgi?id=491674

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2007-12-02 10:01:48 EST
I think I've seen this a few times myself.  Have you seen other applications die
or freeze when running "yum update" or is Evolution just special?
Comment 2 Kjartan Maraas 2007-12-02 11:28:37 EST
Only evolution that I have noticed in recent times IIRC.
Comment 3 Matthew Barnes 2007-12-11 16:12:46 EST
Sounds like this bug could very well be elsewhere.  Can you keep an eye on this
and report back if you see it again?  I haven't seen any yum-related hangs in
the past couple weeks.
Comment 4 Kjartan Maraas 2008-01-03 07:25:16 EST
I filed https://bugzilla.redhat.com/show_bug.cgi?id=427348 now which is very
similar but when trying to start vmware workstation.
Comment 5 Kjartan Maraas 2008-01-06 11:26:55 EST

*** This bug has been marked as a duplicate of 427348 ***

Note You need to log in before you can comment on or make changes to this bug.