Bug 40789 - Problem when ftp is put to a background and then to foreground
Problem when ftp is put to a background and then to foreground
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 17:17 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-15 17:17:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-15 17:17:40 EDT
If I use ftp (or pftp) client
ftp-0.17-6
go to some ftp site, start downloading (command mget *)
then do ctl-Z to suspend command, then bg % to put into background
the ftp will work in background.
when it finishes - it gets suspened (waithing for input)

The problem is:
now if I put ftp client to a foreground ( type %)
the output of ftp command on the screen is not right.

I can still type ftp commands (and they are executed OK)
but I can not see what I type. The output of ftp command
on screen becomes incorrect after suspend and resume.

Similar problem exists with some other commands when 
they get suspended.
Comment 1 Bernhard Rosenkraenzer 2001-05-17 07:50:04 EDT
This is because the terminal control codes are sent nowhere while the process 
is backgrounded.
There's no way to fix this short of rewriting readline.

If you need to get files without having ftp constantly bothering you, use 
ncftpget or ftpcopy instead of backgrounding the ftp process.


Note You need to log in before you can comment on or make changes to this bug.