Bug 407891 - undefined macro in pam_ssh.spec
Summary: undefined macro in pam_ssh.spec
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pam_ssh   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Patrice Dumas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-02 15:47 UTC by Florian La Roche
Modified: 2007-12-14 15:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 15:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florian La Roche 2007-12-02 15:47:04 UTC
Description of problem:
%postun
if [ "$1" -eq "0" ]; then
  semodule -r %{module} || :
fi


In the above scriupt "module" is not a defined macro, so the string
"%{module}" is copied into the script.

"module -> name" should probably fix this.

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dmitry Butskoy 2007-12-03 12:11:26 UTC
Patrice,

maybe just drop the recent SELinux addons? Since something was added to the
system-wide polycies? (I've already proposed this somewhere recently...)

Comment 2 Martin Ebourne 2007-12-10 13:19:51 UTC
Yes, drop the selinux changes from pam_ssh since it has now been fixed directly
in the policy.

Comment 3 Fedora Update System 2007-12-10 20:46:12 UTC
pam_ssh-1.92-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pam_ssh'


Note You need to log in before you can comment on or make changes to this bug.