Bug 40791 - (SCSI BUSLOGIC)BusLogic timeout error, when installing
(SCSI BUSLOGIC)BusLogic timeout error, when installing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 17:51 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-15 17:51:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9) Gecko/20010505

Description of problem:
Installed hangs and times out when loading anaconda, after selecting what
kind of install to use. 



How reproducible:
Always

Steps to Reproduce:
1. Start installation in "expert text" mode
2. Choose Custom Install (or any install)

	

Actual Results:  The system, in the first virtual window, only showed the
blue background of the RedHat installer.

Expected Results:  It should have continued and allowed me to install RH7.1

Additional info:

Error message encountered, after htting "Alt-F4":

<4>SCSI: aborting command due to timeout: pid 0, scsi 0, channel 0, id 0,
lun 0 0x28 00 00 00 00 00 00 00 02 00
<4>scsi0: Aborting CCB#39 to target 0
<4>SCSI host 0 abort (pid 0) timed out - resetting
<4>scsi0: Sending bus device reset CCB#40 to target 0
<4>SCSI host 0 abort (pid 0) timed out - resetting - trying harder
<4>SCSI bus is being reset for host 0 channel 0.
<4>scsi0: Resetting BusLogic BT-950 due to target 0
<4>scsi0: *** BusLogic BT-950 Initialized Successfully ***

Then, it repeats the error message indefinately.

I have a Mylex FlashPoint LT Ultra SCSI, with lated BIOS, running two 9.1
gig Quantum Ultra SCSI hard drives and a Yamaha SCSI CD-RW and a Teac SCSI
CD-ROM.  I'm trying to install RH7.1 from a boot disk and an IDE
CD/DVD-ROM.  My system is an Athlon 700 Slot A, 256 mb RAM.  Motherboard is
an MSI-6167 with latest BIOS. I have a RIVA TNT2 video and 3com 3c905c
network card and a SoundBlaster AWE64 ISA.

I've tried all of the tricks related to the recent aic7xxx, including the
boot disk (I thought the problems were similar) but it didn't work.

RH7 worked fine with my system.
Comment 1 Matthew Saltzman 2001-05-17 09:39:35 EDT
I believe I have this problem as well.

P-III, 440BX chipset, Mylex Flashpoint, thee 9G drives, DAT, CD-ROM.

Attempting a hard-disk install.  Boot from floppy, select text install, enter
location of isos,
hang.  On console 4, a continuous stream of SCSI bus resets.
Comment 2 Brent Fox 2001-05-17 14:03:21 EDT
Can you try booting with 'linux ide=nodma'?  Does that help?
Comment 3 Need Real Name 2001-05-17 14:20:04 EDT
I tried "linux ide=nodma" and it doesn't help.  Same situation.
Comment 4 Matthew Saltzman 2001-06-20 16:52:35 EDT
Is there any progress on this issue?

I can also confirm that linux ide=nodma is no help.
Comment 5 Arjan van de Ven 2001-06-20 16:57:20 EDT
Buslogic worked in our testlab.
"noprobe" is the only option I can think of that might make a difference
Comment 6 Matthew Saltzman 2001-07-03 17:30:35 EDT
I finally got to try "noprobe" (the machine lives in Baltimore and I live in
South Carolina) and it didn't help.  It asks for a controller, and when BusLogic
is selected, it goes through the same sequence of events.

Here, laborously copied off the screen, is the sequence of messages.  This time
I tried the install off of CD (SCSI ID 3).

After whaqt appear to be the usual startup messages, ending with "Unable to
identify CD-ROM format", we see:

SCSI Aborting command due to timeout pid 10, scsi 0, channel 0, id 3, lun 0
	0x28 00 00 04 32 7a 00 00 06 00

Aborting CCB #666 due to Target 3
SCSI host 0 abort (pid 0) timed out - resetting
SCSI bus is being reset for host 0 channel 0
SCSI0: Sending Bus Device reset CCB #667 to Target 3
SCSI host 0 abort (pid 0) timed out - trying harder
SCSI bus is being reset for host 0 channel 0
SCSI0: Resetting Buslogic BT-950 due to Target 3
SCSI0: *** Buslogic BT-950 Initialized Successfully ***

Then the last three messages repeat indefinitely.

I installed an Adaptec 2950 and the install went off without a hitch.  Now I
will try to use the BusLogic as a second adapter.

This card had the RAID BIOS installed.  I have two more machines to install when
I return from traveling.  One has a BT-950 without the RAID, and the other has a
BT-958.
Comment 7 David Allen 2001-07-21 02:11:16 EDT
I have the same problem.

Motherboard is Asus P5A Super 7 with ALi Aladdin V AGPset chipset w/ESS Solo1
256MB PC100 SDRAM
Mylex BT-950 FlashPoint LW SCSI Controller w/RaidPlus
  BIOS Version 2.02N (64MB)
  BIOS Address @ C8000h
  Port Address @ A800h

SCSI ID=0: Seagate 39173W Hard Drive
SCSI ID=1: Seagate 19101W Hard Drive
SCSI ID=2: Toshiba XM-6201TA CD-ROM Drive

Matrox G200 Video Card
3Com 3C905TX Network adapter

I get virtually the same set of messages at console F4 as mjs and bfotovic.
Except the CCB code is #1311 and #1312. IDE is disabled in the motherboard BIOS
as this is an all-SCSI box. System continually tries to read Target 2 (CD-ROM),
and upon failure, resets SCSI bus. The OS does recognize the BT-950 itself.

I am attempting an upgrade to an existing Redhat 5.2 system which installed
without incident on the same hardware and has been running flawlessly 24/7 for
over two years (average uptime over 120 days).
Comment 8 Need Real Name 2001-12-05 20:49:12 EST
Me too.  :) -- PII SMP; BusLogic Model BT-958 PCI -- Firmware Version: 5.07B

Upgrading from kernel-smp-2.4.3-12 to kernel-smp-2.4.9-12 (rh7.1) failed, with
similar timeout errors.  According to the support web site for the card,  the
latest version of firmware is "4.96F/5.06I"
I also encountered similar troubles with a kernel I compiled...

A kb article on the mylex support site suggests that firmware v. 5.07B may have
issues: "Firmware 5.07B has a known problem with the diagnostics, and with
hanging, and the work-around is to reflash the adapter back to firmware 5.06I or
5.06J."  

An email to their support apparently got filed in /dev/null.  I'm building a new
machine, and after that's running I'll dig up a DOS boot diskette and try a
"flashback."

http://www.mylex.com/support/productgd/index.html
Comment 9 Matthew Saltzman 2001-12-05 21:46:17 EST
>A kb article on the mylex support site suggests that firmware v. 5.07B may have
>issues: "Firmware 5.07B has a known problem with the diagnostics, and with
>hanging, and the work-around is to reflash the adapter back to firmware 5.06I or
>5.06J."  

You definitely want to do this, probably with 5.06J (available from
http://www.dandelion.com/Linux/BusLogic.html).

I installed 7.2 from a CD-ROM on a BT-958 with that BIOS combination to an
ATA-100 disk drive, and it's working fine so far.  Haven't had a chance to try
the BT-950 yet.

Comment 10 Bugzilla owner 2004-09-30 11:39:00 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.