Bug 40792 - anaconda crashes while determining disk space
anaconda crashes while determining disk space
Status: CLOSED DUPLICATE of bug 38448
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 17:53 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 16:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-15 17:53:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win95; U)

Description of problem:
Anaconda reports that it is short by -7k bytes to install the system.  This is a fresh install of RH 7.1.  The disks have installed on ther systems 
without any trouble (ide based system).  This system has both ide (win 9x) and SCSI (adaptec 2940uw) drives.  This was attempted to be 
installed on a 4 gb SCSI hd. Swap was on a different SCSI drive.  There are two exsisting (ext2) fs's that were not formatted, but defined in Disk 
druid.  There are 4 win9x partitions (ide  / SCSI) on the system.

Here is the crash file:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1925, in doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 632, in umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py", line 134, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage/dosf
removeDir: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I515
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>


How reproducible:
Always

Steps to Reproduce:
1. Select either Custom or workstation
2. use diskdruid to identify all partitions
3. install
	

Actual Results:  fails every time.

Additional info:

used expert startup  for I didn't want to lose current ext2 filesystems
I would like to install RH 7.1 instead of RH 6.2 (6.2 was the old system before ide HD install).
Comment 1 Brent Fox 2001-05-16 16:05:25 EDT

*** This bug has been marked as a duplicate of 38448 ***

Note You need to log in before you can comment on or make changes to this bug.