Bug 407981 - X11 screen goes blank on startup
X11 screen goes blank on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 14:04 EST by Han-Wen Nienhuys
Modified: 2008-02-23 15:33 EST (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.7.197-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 17:39:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg logfile. (56.16 KB, text/plain)
2007-12-02 14:04 EST, Han-Wen Nienhuys
no flags Details

  None (edit)
Description Han-Wen Nienhuys 2007-12-02 14:04:38 EST
When the X11 server starts, the screen goes blank, monitor says: no signal. When
switching text (Ctrl-Alt-F1) and back to X, I get signal.



xorg-x11-filesystem-7.1-2.fc6
xorg-x11-fonts-Type1-7.2-3.fc8
xorg-x11-drv-sisusb-0.8.1-9.fc8
xorg-x11-drv-tseng-1.1.0-7.fc8
xorg-x11-drv-v4l-0.1.1-8.fc8
xorg-x11-drv-sis-0.9.3-4.fc8
xorg-x11-drv-nouveau-2.1.5-2.fc8
xorg-x11-drv-avivo-0.0.1-6.fc8
xorg-x11-fonts-truetype-7.2-3.fc8
xorg-x11-drv-fpit-1.1.0-4.fc8
xorg-x11-drv-rendition-4.1.3-5.fc8
xorg-x11-drv-elographics-1.1.0-4.fc8
xorg-x11-drv-apm-1.1.1-7.fc8
xorg-x11-drv-aiptek-1.0.1-5.fc8
xorg-x11-drv-calcomp-1.1.0-4.fc8
xorg-x11-server-utils-7.3-1.fc8
xorg-x11-utils-7.3-1.fc8
xorg-x11-font-utils-7.2-2.fc8
xorg-x11-drv-keyboard-1.2.2-2.fc8
xorg-x11-fonts-100dpi-7.2-3.fc8
xorg-x11-drv-mouse-1.2.3-1.fc8
xorg-x11-drv-citron-2.2.0-2.fc7
xorg-x11-drv-i740-1.1.0-5.fc8
xorg-x11-drv-penmount-1.1.0-3.fc7
xorg-x11-drv-ark-0.6.0-6.fc8
xorg-x11-drv-summa-1.1.0-4.fc8
xorg-x11-drv-digitaledge-1.1.0-4.fc8
xorg-x11-drv-dmc-1.1.0-3.fc7
xorg-x11-drv-palmax-1.1.0-4.fc8
xorg-x11-drv-dynapro-1.1.0-3.fc7
xorg-x11-drv-voodoo-1.1.1-1.fc8
xorg-x11-drv-fbdev-0.3.1-4.fc8
xorg-x11-drv-chips-1.1.1-5.fc8
xorg-x11-drv-ati-6.7.196-1.fc8
xorg-x11-apps-7.3-1.fc8
xorg-x11-xinit-1.0.7-2.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8
xorg-x11-drv-evdev-1.1.2-5.fc8
xorg-x11-drv-mga-1.4.6.1-6.fc8
xorg-x11-drv-magictouch-1.0.0.5-5.fc8
xorg-x11-drv-acecad-1.1.0-5.fc8
xorg-x11-drv-tdfx-1.3.0-6.fc8
xorg-x11-drv-tek4957-1.1.0-4.fc8
xorg-x11-drv-glint-1.1.1-7.fc8
xorg-x11-drv-hyperpen-1.1.0-5.fc8
xorg-x11-drv-jamstudio-1.1.0-4.fc8
xorg-x11-drv-magellan-1.1.0-4.fc8
xorg-x11-drv-ur98-1.1.0-4.fc8
xorg-x11-drv-s3-0.5.0-5.fc8
xorg-x11-xkb-utils-7.2-3.fc8
xorg-x11-xauth-1.0.2-3.fc8
xorg-x11-twm-1.0.3-1.fc8
xorg-x11-server-Xorg-1.3.0.0-33.fc8
xorg-x11-drv-savage-2.1.3-1.fc8
xorg-x11-drv-siliconmotion-1.5.1-3.fc8
xorg-x11-drv-dummy-0.2.0-5.fc8
xorg-x11-drv-microtouch-1.1.0-2.fc7
xorg-x11-drv-nv-2.1.5-2.fc8
xorg-x11-drv-spaceorb-1.1.0-4.fc8
xorg-x11-fonts-misc-7.2-3.fc8
xorg-x11-drv-vesa-1.3.0-10.fc8
xorg-x11-drv-void-1.1.1-6.fc8
xorg-x11-drv-s3virge-1.9.1-5.fc8
xorg-x11-drv-cirrus-1.1.0-5.fc8
xorg-x11-drv-ast-0.81.0-6.fc8
xorg-x11-drv-mutouch-1.1.0-5.fc8
xorg-x11-drv-trident-1.2.3-6.fc8
xorg-x11-drv-i128-1.2.1-1.fc8
xorg-x11-drivers-7.2-9.fc8




How reproducible:

always
Comment 1 Han-Wen Nienhuys 2007-12-02 14:04:38 EST
Created attachment 275101 [details]
xorg logfile.
Comment 2 Han-Wen Nienhuys 2007-12-02 14:05:18 EST
This is on a ppc mac mini with a NEC 2080ux monitor connected to DVI.
Comment 3 Matěj Cepl 2007-12-04 18:15:15 EST
Can we get /etc/X11/xorg.conf as well, please?
Comment 4 Peter Lemenkov 2008-01-19 18:05:13 EST
The same problem.
Comment 5 Peter Lemenkov 2008-01-19 18:06:59 EST
*** Bug 410091 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Weiss 2008-01-20 04:32:18 EST
My Fedora 8 installation has the same problem.

Hardware:

Standard Intel Pentium 4 PC
ATI Radeon 9600 graphic card

Graphics worked with Fedora 6. After upgrade to Fedora 8 I get a blank screen at
the end of the boot process. Switching virtual terminals to vt 1 and back to vt
7 with Ctrl + Alt + F1 and Ctrl + Alt + F7 "fixes" the problem, I get the
display manager login.

Using the commercial ATI driver results in login screen after booting but the
graphic is "moved to the right" by aprox. 20%, leaving the left side of the
screen blank. Switching virtual terminals back and forth also "fixes" this problem.
Comment 7 Matthias Weiss 2008-01-30 05:17:51 EST
I can add some interesting information: 2 days back the 17" TFT no name monitor
died. Today I attached a different TFT monitor (  19" Samsung SyncMaster 191T )
with the same resolution and the black screen at startup is now gone. I can now
see the graphical boot screen and also the login screen appears at the end of
the boot process, no Ctrl + Alt + F1 etc. switching necessary.

In ~ 2 weeks the old 17" monitor will be repaired and I expect the problem will
return again :-( .



Comment 8 Peter Lemenkov 2008-02-18 15:47:00 EST
It seems was fixed already - I updated recently and found that issue was gone.

xorg-x11-drv-ati-6.7.197-1.fc8

Does anybody confirms that this problem was solved? If yes then we should close
this ticket.
Comment 9 Nigel Horne 2008-02-18 15:55:18 EST
Nope, it still fails for me. More correctly I still have the symptoms of bug 
410091 not this bug (which has incorrectly been marked as a duplicate).
Comment 10 Peter Lemenkov 2008-02-18 16:03:37 EST
Sounds silly, but could you please try to connect to some other monitor? 
Comment 11 Nigel Horne 2008-02-18 16:42:16 EST
Are you asking me? Sorry, but I'm not sure if it's me you're asking.

If so then the simple answer is "no", I don't believe I have a suitable monitor 
to plug in to the laptop.
Comment 12 Nigel Horne 2008-02-18 16:44:41 EST
One other thing, why is this set to priority low? I submitted another bug 
410091 as high (because the laptop is useless without a fix) yet that's been 
marked as a dup of this LOW priority bug for some reason. Please correct the 
priority back again.
Comment 13 Han-Wen Nienhuys 2008-02-19 17:39:41 EST
works for me now (mac mini PPC). 

I think Nigel horne is reporting a different bug; can his bug be unmarked as
duplicate?

Comment 14 Matthias Weiss 2008-02-20 03:41:53 EST
The old monitor is repaired, I pluged it on and didn't experience the problem of
the past. For me the problem is gone, independend of the monitor model.

From my point of view this bug can be closed
Comment 15 Nigel Horne 2008-02-23 15:33:30 EST
Still fails for me. I have reopened 410091

Note You need to log in before you can comment on or make changes to this bug.