Bug 40801 - Installer crashes with a bug requester when formatting the linux partitions
Installer crashes with a bug requester when formatting the linux partitions
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 20:47 EDT by steve lanz
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 10:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description steve lanz 2001-05-15 20:47:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in 
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + 
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in 
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + 
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//diskc

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


How reproducible:
Always

Steps to Reproduce:
1.install system
2.fails when it gets ready to format the swap space
3.
	

Actual Results:  get a bug report requester and installation stops

Expected Results:  system installed

Additional info:

seems to be failing on the intall of the swapspace, not sure if it is 
formating that properly or failing to mount, comp is a SONY vaio PCV-
R528DS 128MB Ram, New Maxtor 30GB IDE hard drive, not installed or 
formated with the software that was installed. Installed 20Gb partition 
and win 2000 pro, then attempted to install remaining 9.5GB as linux 
partition and small swap partition
Comment 1 Bernhard Rosenkraenzer 2001-05-16 04:28:02 EDT
This doesn't have anything to do with the mount package. Please try to choose 
the correct component when reporting a bug. It gives you a faster response and 
saves us some work.
Reassigning.

Comment 2 Brent Fox 2001-05-16 16:24:31 EDT
How big were the partitions that you made?
Comment 3 steve lanz 2001-05-20 10:54:18 EDT
the primary nt partition was 20 gig, the native linux was 9gig, and i tried 100mb, 16mb, 32 mb, 64mb and received the same message each time.
Comment 4 Brent Fox 2001-05-21 13:47:23 EDT

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.