Bug 408071 - Anaconda crash (exception thrown) when trying to install.
Anaconda crash (exception thrown) when trying to install.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 15:48 EST by Ruth Ivimey-Cook
Modified: 2007-12-18 13:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 13:54:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruth Ivimey-Cook 2007-12-02 15:48:38 EST
Description of problem:
Anaconda crash (exception thrown) when trying to install from DVD. It lets you
get to the "I'm about to install the packages" stage, when it displays an
exception caught message. Errstr is "Error running swapoff: Cannot allocate
memory".  Command is swapoff.

I tried to save to remote, but the dialog has now hung with no info what
happened, other than no file created.

Version-Release number of selected component (if applicable):

Fedora 8 DVD (verified contents) installing onto Athlon x84_64 system. I'm using
the vnc method of driving it. Memory = 512MB. There is a swap partition on the
HD. Local video (other than vnc) is a Matrox Millenium PCI card (the machine is
a server). I'm install-upgrading it from FC4, so have told install to reformat
/, /var, /boot and keep 3 other partitions, one of which is swap. I've had this
error whether or not I've told it to reformat the swap partition (3 times tried
so far).

How reproducible:
Try to "Install" system!

Steps to Reproduce:
1. Boot
2. Setup VNC
3. Select packages
4. Crash

Actual results:
Crash

Expected results:
Install proceeds!
Comment 1 Jeremy Katz 2007-12-04 17:05:26 EST
Can you attach the traceback you received?
Comment 2 Ruth Ivimey-Cook 2007-12-04 18:16:06 EST
Sorry, I can't. As I noted, the "save to remove" button caused the whole
installer to freeze, and all I could do was reset and start again. After that
happened I would have hand-copied it, but of course the frozen UI had obscured
almost all the info :-(

I did successfully install: the next run, I did the install on a local display
rather than via vnc, I didn't attempt to customise the install, and I used fdisk
and mkswap to reformat the drives before letting anaconda loose. I suspect, but
of course don't know, that the important change was in not trying to customise
the install.

As a side-point, I noted that when installing using vnc, the radio-buttons for
customise were overlain by the Release notes button.
Comment 3 Chris Lumens 2007-12-18 13:54:27 EST
Closing since we are unable to speculate or reproduce for now.  Feel free to
reopen this bug report if you have extra information in the future.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.