Bug 408081 - X11 mode switching problems
X11 mode switching problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 16:42 EST by Ross Tyler
Modified: 2009-01-09 02:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:29:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ross Tyler 2007-12-02 16:42:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
CTRL-ALT-KEYPADPLUS/CTRL-ALT-KEYPADMINUS mode switching does not work (striking keys does nothing) after a fresh install of Fedora 8 on a system (ViewSonic P225f-5 monitor, ATI Technologies Inc Radeon R350 (Radeon 9800) video card) that was having no such problems with Fedora 7. I have been able to correct some of the problems but not all.

My monitor (ViewSonic P225f-5) lost its DDC capability (does not report scan frequency tolerances) while using Fedora 7, and with it the X server's ability to support many modes. I corrected this using system-config-display and manually choosing this monitor and its highest supported resolution. However, this workaround does not work in Fedora 8. Nor does the Fedora 8 problem seem related to this monitor because another well-behaved monitor (ViewSonic PS790) also worked on Fedora 7 but not on Fedora 8.

I installed the livna-packaged fglrx driver which fixed this problem but made it impossible to run compiz (compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing). I reinstalled Fedora 8 (because I could do it quicker than figuring out how to revert to the original radeon driver) and updated to xorg-x11-drv-ati-6.7.196-1.fc8. I was then able to get support for multiple resolutions for the ViewSonic P225f-5 but only after manually adding an appropriate "Virtual xdim ydim" directive to /etc/X11/xorg.conf (why?). I have not been able to get it to work with the ViewSonic PS790 (why?).

Even though I can switch between multiple resolutions on my ViewSonic P225f-5, panning through the virtual desktop does not work whether using the default metacity window manager or the (desktop effects) compiz window manager.



Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-33.fc8

How reproducible:
Always


Steps to Reproduce:
1. Install Fedora 8 on like system (see above)
2. Note failure of CTRL-ALT-KEYPADMINUS behavior

Actual Results:
Nothing

Expected Results:
Zoom in

Additional info:
/etc/X11/xorg.conf:

# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us+inet"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        ModelName    "ViewSonic P225f-5"

        # the ViewSonic P225f monitor's DDC stopped reporting its attributes!
        # (see /var/log/Xorg.*.log).
        # without knowing the scanning bounds, xorg will be very conservative
        # and limit the display to 800x600.
        # this can be corrected by adding a properly configured Monitor section
        # and associating it with the Screen.
        # system-config-display can be used
        # or we can use /usr/share/hwdata/MonitorDB:
        #       ViewSonic; ViewSonic P225f-5; VSC8012; 30-127; 50-160
        # to specify HorizSync and VertRefresh.
        HorizSync    30.0 - 127.0
        VertRefresh  50.0 - 160.0

        # specify the Gamma appropriate for this videocard/monitor.
        Gamma        1.16
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes   "2048x1536" "1920x1440" "1856x1392" "1792x1344" "1600x1200" "1400x1050" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480"
                # ? default Virtual X Y should accomodate above Modes but ...
                Virtual 2048 1536
        EndSubSection
EndSection
Comment 1 Ross Tyler 2007-12-03 09:42:49 EST
I have another system (HP L2035 Flat Panel Monitor and Intel Corporation
82945G/GZ Integrated Graphics Controller) that worked fine on Fedora 7 but has
been broken by Fedora 8. I cannot get CTRL-ALT-KEYPADMINUS to do anything. I
have tried manually configuring the display with system-config-display to no avail.
Comment 2 Ross Tyler 2007-12-07 11:02:37 EST
On the system (ViewSonic P225f-5 monitor, ATI Technologies Inc Radeon R350
(Radeon 9800) video card) that I have got zoom (but not pan) to work, there is
another anomoly:

When zoomed, sometimes the bottom panel (which should be anchored to the bottom
of the virtual desktop offscreen) is floating somewhere in the middle of the
screen. And when I move the cursor over it it appears to "autounhide/autohide"
(moves up and down) over and over again without any further cursor movement.
Comment 3 Bug Zapper 2008-11-26 03:47:29 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-01-09 02:29:37 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.