Bug 408141 - wpa_supplicant leaks about 100KB per hour on my laptop
wpa_supplicant leaks about 100KB per hour on my laptop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 19:12 EST by Pádraig Brady
Modified: 2008-01-16 16:52 EST (History)
0 users

See Also:
Fixed In Version: 0.5.7-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 16:52:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2007-12-02 19:12:24 EST
wpa_supplicant-0.5.7-16.fc8 leaks about 100KB per hour on my
intel 2200BG laptop.

I noticed it using 46MB once. Monitoring it again now shows:

$ while true; do ps -C wpa_supplicant -orss=; sleep 300; done
11656
11668
11676
Comment 1 Dan Williams 2007-12-03 10:04:23 EST
neat; will try to track this down.  thanks for the heads-up
Comment 2 Dan Williams 2007-12-06 18:09:14 EST
FYI; I'm pretty sure I know where the leaks are (2 of them) and will fix them in
the next update.
Comment 3 Dan Williams 2007-12-06 18:34:10 EST
Can you test out http://koji.fedoraproject.org/koji/taskinfo?taskID=280449 when
it's done, and see if that fixes the leaks for you?
Comment 4 Pádraig Brady 2007-12-07 06:57:53 EST
That package seems to start 2 wpa_supplicant processes:
$ ps -C wpa_supplicant -oargs=
wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -ieth1 -Dwext -B
/usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f

Neither of them leak though :)
$ while true; do ps -C wpa_supplicant -orss=; sleep 300; done
  812
 1912
  812
 1912
  812
 1912
  812
 1912

thanks Dan.
Comment 5 Dan Williams 2007-12-07 07:01:39 EST
Hmm, I guess we need a way to ensure that the new init stuff doesn't start
things unelss they are configured.  Can you obtain the output of:

/sbin/chkconfig --list | grep wpa_supplicant

for me to ensure that you have wpa_supplicant turned _off_ at boot time?  It
doesn't matter for NetworkManager, because NetworkManager starts wpa_supplicant
on-demand through dbus service activation, so only uses it when it needs to.

However, if the new initscript bits start wpa_supplicant unconditionally now,
that's wrong and I need to fix that.
Comment 6 Pádraig Brady 2007-12-07 08:06:00 EST
Hmm RSS went from 1912 to 1916 after 20 mins,
but has held steady there for the last hour,
so I still think the leak is gone.

As for 2 processes being started, wpa_supplicant _is_ started
in runlevel 5 (and previously has failed due to eth1 not being
available at that time).
I did /etc/init.d/wpa_supplicant restart, after which I got both processes.
I'll turn wpa_supplicant off in runlevel 5 as you suggest.
So I think this is all OK also.
Comment 7 Dan Williams 2007-12-07 09:38:49 EST
Yeah, if you're using NetworkManager exclusively you don't need to use the
/etc/init.d facilities; you can (as root) simply 'killall -TERM wpa_supplicant'
and it'll get started again automatically when NM needs it.
Comment 8 Fedora Update System 2007-12-07 16:31:21 EST
wpa_supplicant-0.5.7-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant'
Comment 9 Dan Williams 2008-01-16 16:52:37 EST
Should be long-fixed with -19 and later

Note You need to log in before you can comment on or make changes to this bug.