Bug 40815 - Exception occurred during Redhat 7.0 installation.
Exception occurred during Redhat 7.0 installation.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 23:08 EDT by Ong Hui Ling
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 23:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anacdump captured during exption occurred (1.33 KB, text/plain)
2001-05-15 23:09 EDT, Ong Hui Ling
no flags Details

  None (edit)
Description Ong Hui Ling 2001-05-15 23:08:10 EDT
Description of Problem:
System to be installed with Linux Redhat 7.0 (boxed set): 
Compaq Proliant ML530 (System BIOS P19 11/8/2000) with :
- 1.153GB RAM, 
- 2 units of Pentium Xeon III 1.0GHz processors, 
- Compaq Smart Array 5300 controller (firmware Rev 1.62A), 
- one internal Compaq SCSI DDS-3 tape drive, 
- one dual-ported 10/100TX NIC, 
- 5 units of internal 36.4GB Wide-Ultra3 hard disk in RAID5 config.

Steps I used to install:
1.  Run Erased Utility from SmartStart 4.90B
2.  Configure Smart Array 5300 - specifying RAID5 for 5 units of hard disk
3.  Install Compaq System Partition (occupying 3rd partition automatically)
4.  Boot from Redhat7.0 CD1, install using text mode
5.  use FDISK to create the following partition:
    - /boot      (50MB)   - primary * active boot partition
    - /          (2500MB) - extended
    - /usr       (2500MB) - extended
    - /tmp       (300MB)  - extended
    - /var       (300MB)  - extended
    - /home      (500MB)  - extended
    - /usr/local (300MB)  - extended
    - /usr/src   (300MB)  - extended
    - Swap Space (2040MB) - extended

I run the above steps many a time, and I hit the following:
Sometimes, "Exception occurred" before the packages is installed. There 
are times "Exception occurred" after full packages are installed.
There are times, the installation terminated by itself after mounting to 
respective mountpoints. There are times it just hang there after going to 
next screen of fdisk.

Never get to complete the installation at all.
I was able to install Redhat7.0 successfully with Smart Array 3200 with 
Wide Ultra2 disk.

How Reproducible:
Yes, able to re-produce the issue with other systems. Problem encountered 
exactly the same as mentioned above. WIth other systems, I used Smart 
Array 5300 controller (firmware Rev 1.28A) with one 18.2GB Wide-Ultra2 
disk (RAID0) on Proliant 8000 system with 256MB, dual processors.

Steps to Reproduce:
1. During the installation where I have to create partition using FDISK.
   I even tried with Druid, also produce the same problem mentioned above.
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
An Anacdump.txt was produced when the exception occurred. 

Start of Anacdump.txt
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__cal
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1732, in 
doIn
    self.upgrade)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 323, in 
insta
    thisLabel = thisLabel + '-smp'
TypeError: bad operand type(s) for +

Local variables in innermost frame:
thisLabel: None
mainLabelUsed: 1
upgrade: 0
main: None
images: {}
bootpart: cciss/c0d0p1
smpInstalled: 1
liloTarget: cciss/c0d0p1
boothd: cciss/c0d0
rootDev: cciss/c0d0p5◄
fstab: <fstab.NewtFstab instance at 820b0b8>
lilo: boot=/dev/cciss/c0d0p1
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default

perms: 420
self: <lilo.LiloConfiguration instance at 82756e8>
otherList: []
default: None
hdList: <comps.HeaderListFromFile instance at 8264810>
kernelList: [(None, kernel-enterprise, 'enterprise')]
instRoot: /mnt/sysimage

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hda'
sS'progressWindow'
p9

<failed>
End of Anacdump.txt
Comment 1 Ong Hui Ling 2001-05-15 23:09:35 EDT
Created attachment 18554 [details]
Anacdump captured during exption occurred
Comment 2 Brent Fox 2001-05-21 09:42:19 EDT
Have you had a chance to try 7.1?  I did lots of installs of 7.0 with the Compaq
SmartArray controllers, although not the 5300.  All the ones I tried used the
cpqarray module, not the cciss.  I know that the kernel team had a 5300 for
their 7.1 testing, so I would expect it to work.  I finally got my hands on one
in the test lab, so I'll try a test install with 7.1 and see if the problem occurs.
Comment 3 Ong Hui Ling 2001-05-23 01:39:35 EDT
Hi, Brent

What is the outcome of your testing of Smart Array 5300 controller with Redhat 
7.1 ?
Does the installation went through fine ? Would appreciate your reply to advise 
if there is any specific area to watch out.

Thanks in advance for your time to troubleshoot my issue.

Reagards,...Hui Ling
Comment 4 Ong Hui Ling 2001-05-23 07:30:49 EDT
Just want to inform you that I tested Redhat 7.1 and it works fine with Smart 
Array 5300 controller. 

Case closed. Thanks for your time in assisting me.

Regards,....Ong Hui Ling

Note You need to log in before you can comment on or make changes to this bug.