Bug 408151 - Tweaks needed for bluecurve-icon-theme to work well with KDE 4
Tweaks needed for bluecurve-icon-theme to work well with KDE 4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluecurve-icon-theme (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 19:34 EST by Kevin Kofler
Modified: 2008-04-07 19:56 EDT (History)
5 users (show)

See Also:
Fixed In Version: 8.0.2-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 19:56:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2007-12-02 19:34:41 EST
Description of problem:
bluecurve-icon-theme needs some tweaks to work well with KDE 4. Here's the 
ones I currently know about:
* edit-find-replace.png is in the stock directory. The KDE icon loader will 
not find it there, we need it in actions.
* in actions, please symlink reload.png to view-refresh.png
* in actions, please symlink edit_add.png to edit-add.png and edit_remove.png 
to edit-remove.png (the underscored names need to be kept for KDE 3 
compatibility, but KDE 4 uses dashes instead)

Version-Release number of selected component (if applicable):
bluecurve-icon-theme-8.0.0-1
Comment 1 Kevin Kofler 2007-12-02 19:55:15 EST
Here's some more, to make Dolphin (and thus pretty much everything in KDE 4 
which manages files) happy:
* in mimetypes, there's a lot of icons with a gnome-mime- prefix. KDE 4 needs a 
version without the gnome-mime- prefix. This affects gnome-mime-text-csrc.png 
and many others.
* mimetypes/folder.png should be symlinked to mimetypes/inode-directory.png, 
Dolphin uses that.
Comment 2 Ray Strode [halfline] 2007-12-02 20:35:34 EST
Hi Kevin,

Feel free to make any changes you want to get it working well with KDE.

You can get at it with:

git clone git://git.fedoraproject.org/themes/bluecurve-icon-theme

then just make you your changes. 

$ git-mv src dest
  will move a file around
$ ln -s src dest; git-add dest
  will create a new symlink in the package

then just git-commit -a and git push

If you want to do a release modify configure.ac, git commit -a, git tag 8.0.1
(or whatever) then git push --all

If you don't want to futz with git, just tell me and I'll make the changes.  You
 don't have to block on me, though.  You're now on the gitthemes acl.
Comment 3 Kevin Kofler 2007-12-16 20:10:35 EST
I'm going to take care of this ASAP, I've been busy with other KDE-4-related 
stuff.
Comment 4 Kevin Kofler 2008-01-03 17:36:24 EST
Ugh, there's another flood of icon renamings going on in KDE 4 just before the 
4.0.0 tagging, so I'll best wait until the 4.0.0 release before doing any icon 
theme tweaks. (It's really annoying how they're allowing these renames to go on 
irrespectively of all freezes, they also break third-party apps, not just 
third-party icon themes, but we can't do anything about that.)
Comment 5 Kevin Kofler 2008-04-05 14:26:17 EDT
I'm looking into this now. F9 is coming close, oops...
Comment 6 Kevin Kofler 2008-04-05 14:53:34 EDT
Hmmm, what happened to the bluecurve-icon-theme git repo? I know there has been 
some restructuring at fedorahosted, I read both of Mike McGrath's mails about 
it, but I still can't find the current location.
Comment 7 Kevin Kofler 2008-04-05 15:06:12 EDT
Meanwhile, some updates:

> * in actions, please symlink edit_add.png to edit-add.png and edit_remove.png
> to edit-remove.png
This has changed to:
* in actions, please symlink edit_add.png to list-add.png and edit_remove.png 
to list-remove.png
(It has been renamed in the final KDE 4.0.)

* in actions, locationbar_erase.png should be symlinked to edit-clear.png
Comment 8 Ray Strode [halfline] 2008-04-05 22:32:58 EDT
hmm, not sure.

Do you know Mike?
Comment 9 Mike McGrath 2008-04-06 00:38:04 EDT
I just got ahold of Duffy to see whats going on there.  We can easily put the
repos back up we just want to make sure they're not being stored / used
somewhere else.  I'll likely get to this tomorrow or Monday if thats cool with
you guys?  Its been many months since these repos were used.
Comment 10 Ray Strode [halfline] 2008-04-06 13:56:45 EDT
we're not talking about the bluecurve repo run by Mairin.  We're talking about
the bluecurve-icon-theme repo that fell out of my redhat-artwork split up before F8.
Comment 11 Mike McGrath 2008-04-07 09:25:42 EDT
These are the themes I've got, do they all need to be moved to fedorahosted?

bluecurve-classic-metacity-theme
bluecurve-gdm-theme
bluecurve-gnome-theme
bluecurve-gtk-themes
bluecurve-icon-theme
bluecurve-kde-theme
bluecurve-kdm-theme
bluecurve-kwin-theme
bluecurve-metacity-theme
bluecurve-qt-engine
bluecurve-xmms-skin
fedorabubbles-gdm-theme
fedoradna-gdm-theme
fedoradna-kdm-theme
fedoraflyinghigh-gdm-theme
fedoraflyinghigh-kdm-theme
fedora-gnome-theme
fedora-icon-theme
fedorainfinity-gdm-theme
fedorainfinity-screensaver-theme
fedora-screensaver-theme
Comment 12 Kevin Kofler 2008-04-07 09:39:04 EDT
*-gdm-theme, *-kdm-theme and bluecurve-kwin-theme are no longer in Rawhide, so 
I guess the repositories for those aren't needed anymore, but maybe we still 
want them for reference purposes?

AFAIK, the others are still being shipped (unless I missed a dropped one), so I 
think we should migrate them all.
Comment 13 Kevin Kofler 2008-04-07 09:40:09 EDT
(I think it's best to let Ray Strode decide what to do with the repos for the 
dropped themes.)
Comment 14 Ray Strode [halfline] 2008-04-07 09:43:15 EDT
Let's just move them over as people need them, so they don't just rot.

Can you move bluecurve-icon-theme over for now?
Comment 15 Mike McGrath 2008-04-07 10:10:26 EDT
Ok, these all exist now:

http://git.fedorahosted.org/git/

ssh://git.fedorahosted.org/git/*

git://git.fedorahosted.org/git/*

rsync://git.fedorahosted.org/git/*
Comment 16 Kevin Kofler 2008-04-07 17:20:15 EDT
> * edit-find-replace.png is in the stock directory. The KDE icon loader will 
> not find it there, we need it in actions.

Looks like this has actually been fixed in KDE, so I won't change that for now.

Note You need to log in before you can comment on or make changes to this bug.