Bug 408231 - Error when printing using evince
Error when printing using evince
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-02 22:31 EST by Rodd Clarkson
Modified: 2009-01-09 00:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:24:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodd Clarkson 2007-12-02 22:31:52 EST
Description of problem:

I have a Brother HL-5250DN Laser Printer.  I'm using the default settings
applied when setting the printer up using system-config-printer except that I've
changed the page size to A4 (which sadly it doesn't default to).

The Print Test Page option works fine.

If I print from OpenOffice.org, xpdf, gedit or the terminal (using `lpr
filename' for example) then it prints fine.

However, when I print a PDF from evince, I get a single page that has a shaded
box that says:

ERROR NAME;
  ioerror
COMMAND;
  fill
OPERAND STACK;

If I print to file (the resulting PDF previews fine), but these PDF's don't
print either, giving the same error.


Version-Release number of selected component (if applicable):

poppler-0.6-2.fc8
evince-2.20.1-2.fc8


How reproducible:

Every time.

Steps to Reproduce:
1. Open a PDF in evince (I just double click one)
2. Select File > Print
3. Select the appropriate printer (if not default) and then click OK
Comment 1 Rodd Clarkson 2007-12-03 22:40:44 EST
Okay, this seems related to another problem I've been having with getting evince
to render some PDF's correctly.

see: http://bugzilla.gnome.org/show_bug.cgi?id=331483
and: http://bugs.freedesktop.org/show_bug.cgi?id=9846

I've updated to the cairo in updates-testing which seems to have addressed the
rendering issues on the screen, and it's also had some positive affects on
printing.  One will now print, but only the first page, others seems to choke
under the size of the file for printing, and others still put out the same error
message.

The file for download here is a good example of one that chokes.
http://www.dragonsfoot.org/php4/archive.php?sectioninit=AD&fileid=162&watchfile=0

When I do File > Print and then do a Print Preview, it takes forever to both
open the print preview window, and then to display each of the pages in the window.

This file will only print the first of the two pages.
http://www.dragonsfoot.org/php4/archive.php?sectioninit=CS&fileid=3&watchfile=

It's only a small file and it renders quickly, but even in print preview I can
only get one page to print.  If you print page two using Range (set to 2) then
it prints page two.




Comment 2 Bug Zapper 2008-11-26 03:47:43 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-01-09 00:24:15 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.