Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 40831 - Text entry box gets moved by error message
Text entry box gets moved by error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cameron Prince
wbirkhea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-16 01:05 EDT by Jay Turner
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 12:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-05-16 01:05:36 EDT
Description of Problem:
If you enter an incorrect credit card number in the payment details screen,
the screen refreshes to inform you of the error, but scanning down the
page, notice that the card number and expiration date entry fields have
been pushed far to the right because of the error message stating that the
credit card failed the  LUHN-10 check

How Reproducible:
Always

Steps to Reproduce:
1. Log into http://bmantest.meridian.redhat.com/cgi-bin/store
2. Place something in the cart and start the checkout process
3. On the payment details screen, enter a fake credit card number which
   will fail the LUHN-10 check
4. Attempt to continue with the checkout and will be informed there is an
   error on the submission
5. Scroll down to Credit Card Information and notice how the entry fields
   have been pushed to the right

Actual Results:


Expected Results:
Error message display should not affect the layout of the fields on the screen.

Additional Information:
Comment 1 David Totten 2001-05-16 12:33:40 EDT
This has now been fixed on <a
href="http://webdevel.redhat.com/cgi-bin/store">webdevel.redhat.com/cgi-bin/store</a>
Comment 2 David Totten 2001-05-16 12:34:42 EDT
oops :) I guess I didn't need all of the html stuff. Boy bugzilla is cool!
Comment 3 Jay Turner 2001-05-16 14:13:30 EDT
Looks good on webdevel.  Closing out this issue.

Note You need to log in before you can comment on or make changes to this bug.