Bug 408341 - corrupted python garbage collector
corrupted python garbage collector
Status: CLOSED DUPLICATE of bug 404911
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 01:50 EST by Andrea Santilli
Modified: 2007-12-03 02:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 02:00:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Santilli 2007-12-03 01:50:14 EST
Description of problem:
I noticed this bug while running gimmie 0.2.8 (the app version)
As soon as I try to open one of the menus I get the following error:
 !!! net.sf.gaim.GaimService D-BUS service not available.
 !!! Error parsing ~/.gaim/accounts.xml: No such file or directory
 !!! im.pidgin.purple.PurpleService D-BUS service not available.
 !!! Error parsing ~/.purple/accounts.xml: No such file or directory
 *** Reloading TopicRunningList: Running Applications
 *** Reloading TopicRunningList: Opened Documents
 *** Reloading TopicRunningList: Active Conversations
 *** Reloading TopicRunningList: Computer Running Source
 *** Reloading TopicRunningList: Running Applications
 *** Scaling image of height 32 to 48: win-group://Firefox
 *** Scaling image of height 32 to 48: win-group://andrea@shining:~/Scrivania/gimmie
 *** Reloading TopicRunningList: Opened Documents
 *** Reloading TopicRunningList: Active Conversations
 *** Reloading TopicRunningList: Computer Running Source
 *** Scaling image of height 32 to 48: win-group://andrea@shining:~/Scrivania/gimmie
 *** Scaling image of height 32 to 48: win-group://Firefox
python: Modules/gcmodule.c:276: visit_decref: Asserzione `gc->gc.gc_refs != 0'
fallita.
159a07d9-6f0e-830e-568d27a1-771d35e5 is dumped

('asserzione fallita' means 'assertion failed')
I googled around to see what produces this error and it looks like the cause of
this is a corrupted python garbage collector.
Please also take a look at this page http://bugs.archlinux.org/task/6694 since
changing the CFLAGS seems to fix this problem.

Version-Release number of selected component (if applicable):
python-2.5.1-15.fc8

How reproducible:
always while running gimmie 0.2.8

Steps to Reproduce:
1. run an app like gimmie
2. try to open the menu
3. the app crashes
Comment 1 Deji Akingunola 2007-12-03 02:00:49 EST

*** This bug has been marked as a duplicate of 404911 ***

Note You need to log in before you can comment on or make changes to this bug.