Bug 40838 - vncviewer misbehaves with some unusual kbd maps
vncviewer misbehaves with some unusual kbd maps
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-05-16 03:07 EDT by Aleksey Nogin
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-07 15:52:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Remote xev output - "bad" (2.59 KB, text/plain)
2001-05-16 03:17 EDT, Aleksey Nogin
no flags Details
Remote xev output - "good" (2.35 KB, text/plain)
2001-05-16 03:18 EDT, Aleksey Nogin
no flags Details

  None (edit)
Description Aleksey Nogin 2001-05-16 03:07:37 EDT
Description of Problem:
I have a keyboard map that allows me to use Shift-Shift combination to
switch between English and Cyrillic keyboard maps:
% xmodmap -pk -pm | grep Shift
shift       Shift_L (0x32),  Shift_R (0x3e)
     50         0xffe1 (Shift_L)        0xfe0a (ISO_Prev_Group)
     62         0xffe2 (Shift_R)        0xfe08 (ISO_Next_Group)
Now if I start vncviewer, after the first time I use Shift (the single one,
not the Shift-Shift), vncviwer will start sending Shift-xxx events instead
of xxx events (for xxx in mouse click, Enter key press, etc).

How Reproducible:

Steps to Reproduce:
1. Run 
xmodmap -e "keysym Shift_L = Shift_L ISO_Prev_Group" -e "keysym Shift_R =
Shift_R ISO_Next_Group" 
2. Start vncviewer
3. Press Shift-A, then (after Shift is released) press Enter (or click mouse)

Actual Results:
You get Shift-Enter (or Shift-mouseclick) event in the remote VNC session.

Expected Results:
You get Enter (or mouseclick) event in the remote VNC session.

Additional Information:
- I am using XFree86 v4 and KDE desktop. I do not have any problems like
that with any applications except for vncviewer.
- If I press F8 or leave vncviewer window and come back, the vncviwer
temporarily reverts to normal state (until I press Shift again).
- If I chose to use Shift-CapsLock combination for switching groups instead
of Shift-Shift:  
lock        Caps_Lock (0x42)
     66         0xffe5 (Caps_Lock)      0xfe08 (ISO_Next_Group)
that everything works (but I have to get used to using a new key combination).
Comment 1 Aleksey Nogin 2001-05-16 03:17:44 EDT
Created attachment 18572 [details]
Remote xev output - "bad"
Comment 2 Aleksey Nogin 2001-05-16 03:18:28 EDT
Created attachment 18573 [details]
Remote xev output - "good"
Comment 3 Aleksey Nogin 2001-05-16 03:21:18 EDT
Both xev outputs show what happens when I press the following keys:
a; LShift-a; a; Enter
The first output was produced after I ran (locally)
xmodmap -e "keysym Shift_L = Shift_L ISO_Prev_Group" -e "keysym Shift_R =
Shift_R ISO_Next_Group"
before starting vncviewer; and the second one was produced when I ran
modmap -e "keysym Shift_L = Shift_L" -e "keysym Shift_R = Shift_R"
before starting vncviewer.
Comment 4 Bill Nottingham 2006-08-07 15:45:16 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Aleksey Nogin 2006-08-07 15:52:39 EDT
Have not seen this in a long time.

Note You need to log in before you can comment on or make changes to this bug.