Bug 408411 - b43 doesn't know a bcm94311mcg pci id set (I believe this is supported)
b43 doesn't know a bcm94311mcg pci id set (I believe this is supported)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 04:11 EST by Trever Adams
Modified: 2008-05-13 14:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 14:37:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (4.45 KB, text/plain)
2007-12-05 01:30 EST, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2007-12-03 04:11:50 EST
Description of problem:
The bcm4311mcg in my system is not completely known by lspci, it is definitely
not known by the in kernel package b43 driver. I believe, based on various
websites, that this is a supported device. It probably just needs to be added to
the pci-id database and to whatever part of the b43 driver. The pci-ids and the
rest are found in the "Additional info" section below.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8

Additional info:
03:00.0 Network controller [0280]: Broadcom Corporation BCM94311MCG wlan
mini-PCI [14e4:4311] (rev 02)
        Subsystem: Hewlett-Packard Company Unknown device [103c:1374]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at f6000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
Comment 1 John W. Linville 2007-12-03 08:44:52 EST
That PCI ID already is supported.  However, the wireless core on that device 
is only recently supported and is still in development.

A preliminary patch supporting that device is available in the -63.fc8 kernel.  
Please try that kernel (should be in updates now/soon).  Does it work for you?
Comment 2 Mark Eackloff 2007-12-03 22:10:21 EST
Have never configured a wireless card.  Having trouble with this same device on
HP notebook powered by AMD Turion64x2.  Running kernel 2.6.23.8-63.fc8.  Device
does not show up in hwconf.  Last line of lspci is:
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)
That's the only mention of the device from lspci.  I probaBLY don't know what
I'm doing but hope the above yields a clue.
Comment 3 Trever Adams 2007-12-03 23:10:41 EST
I am sorry. I probably wouldn't have filed the bug, except the chip was listed
as supported in messages that were dated earlier this year.

With the -63 kernel, I can see the available networks, it even tries to connect.
I am not sure which stage if fails in other than I never seem to get an IP address.

Thank you for pursuing this issue. It works better than it did. Thank you.
Comment 4 John W. Linville 2007-12-04 17:13:47 EST
Please attach the contents of /var/log/messages after trying to connect.
Comment 5 Trever Adams 2007-12-05 01:30:45 EST
Created attachment 277701 [details]
/var/log/messages

As I said, it just seems to fail on dhcp.
Comment 6 Martí­n Marqués 2008-01-05 07:06:10 EST
May I add to this:

I have a Compaq Presario F500 with this broadcom wireless which was working like
a charme in F7. After an upgrade it stopped working.

Well not really. It connects, sometimes, and after some time it disconnects
(using NM, not network). I found out that if I was less then a meter from the
AP, disconnections didn't happen anymore.

It's been about 2 weeks already, and I tried almost everything I thought could
help. What I did now is install a kernel from Fedora 7 and the wireless
connection is working (I'm sending this message from my Laptop using the
wireless connection right now).

I have seen some discussion about the problems that F8 has with the b43 driver
in the broadcom driver list (the linux driver).

I'm going to try the linux-2.6.24-rc6 kernel to see if things are fixed there
later. I'll feed back and information needed.
Comment 7 Martí­n Marqués 2008-01-06 10:04:20 EST
FYI, kernel 2.6.24-0.133.rc6.git8.fc9 from rawhide works like a charm, and I was
able to install it without needing anything else from rawhide.
Comment 8 Trever Adams 2008-01-06 18:46:40 EST
I can second this. However, kernel-2.6.24-0.136.rc6.git12.fc9, has a lot of bugs
that make it unusable. (rtc rtc0 symlink problems are back, cannot access the
clock with any known method, etc.). Can the wifi drivers be ported to a working
f8 kernel? (This is posted via the driver that works.)
Comment 9 John W. Linville 2008-01-06 21:27:11 EST
-101.fc8 should have a b43 driver identical to the rawhide kernels cited 
above...do those kernels work for you?
Comment 10 Trever Adams 2008-01-07 18:18:22 EST
This does not seem to have been pushed yet. I don't even see it at
download.fedora.redhat.com
Comment 11 John W. Linville 2008-01-07 19:55:55 EST
They have not yet made it through the release process.  You can find them in 
the build system here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=30116
Comment 12 Trever Adams 2008-01-08 03:23:29 EST
Yes. This fixes it. If Martí­n Marqués agrees, this bug should be closed as
fixed. Thank you John for your prompt and accurate responses.
Comment 13 Chuck Ebbert 2008-01-08 16:20:51 EST
I have the same device as Trever and it still doesn't work for me with kernel 101.

It just keeps repeating this after successfully associating:

  b43-phy0 debug: RX: Packet dropped

Then NetworkManager pops up and asks for the key again.
Comment 14 Martí­n Marqués 2008-01-10 12:57:46 EST
I second Trevor in the fact that kernel -101.fc8 works.

Chuck, never seen those lines in my messages log. What board do you have and
what configuration are you using? Also, try the broadcom-list.
Comment 15 Chuck Ebbert 2008-01-10 13:05:23 EST
03:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)
        Subsystem: Hewlett-Packard Company Unknown device 1374
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at c8000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [58] Vendor Specific Information
        Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
        Capabilities: [d0] Express Endpoint IRQ 0
Comment 16 Chuck Ebbert 2008-01-10 13:24:01 EST
Looks like the device may be disabled by the front-panel switch. Is there any
way to override that?
Comment 17 Martí­n Marqués 2008-01-10 13:54:15 EST
Chuck, just put the switch on. What's the problem with it?
Comment 18 Chuck Ebbert 2008-01-10 14:36:01 EST
(In reply to comment #17)
> Chuck, just put the switch on. What's the problem with it?

Nothing happens when I toggle it (the light stays orange when it should change
to blue.)
Comment 19 John W. Linville 2008-03-07 09:18:45 EST
http://marc.info/?l=linux-wireless&m=120488924708343&w=2

Sometimes the RF kill switches can be hard to move, apparently. :-)

This devices seems to have been supported by b43 for some time now.  Is this 
still a problem?
Comment 20 Trever Adams 2008-03-07 18:42:25 EST
Mine has worked since I said it did in my post on 2008-01-08 03:23 EST. Chuck is
the one we need to hear from. (In fact it works great for me.)
Comment 21 John W. Linville 2008-03-10 09:28:53 EDT
Sorry, I meant to NEEDINFO Chuck instead...
Comment 22 Trever Adams 2008-03-28 16:56:50 EDT
Chuck, do you have the needed information for John? I would like to close this
bug or otherwise not see it.
Comment 23 John W. Linville 2008-05-13 14:37:05 EDT
Closed based on lack of response...please reopen if the problem persist -- 
thanks!

Note You need to log in before you can comment on or make changes to this bug.