Bug 40855 - imapd segfaults on some mailboxes
imapd segfaults on some mailboxes
Status: CLOSED DUPLICATE of bug 20858
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-16 07:41 EDT by Thais Smith
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 03:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thais Smith 2001-05-16 07:41:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I have a mailbox file which will cause imapd to segfault. See attachment.

How reproducible:
Always

Steps to Reproduce:
1. Copy offending file into IMAP maildir
2. Ask imapd to open that folder
3. Watch impad go pow
	

Additional info:
Comment 2 Mike A. Harris 2001-05-16 12:12:58 EDT
What version of imapd are you running?

rpm -q imap

If it isn't the latest errata update, could you update to the latest one
and test it for the problem also?

If the problem persists, I will create a new imap rpm package for you to
test ASAP, which will become an errata for all releases likely.
Comment 3 Thais Smith 2001-05-16 12:23:24 EDT
executor$ rpm -q imap
imap-2000-4

I believe that's the latest, unless I'm rsyncing my updates from the wrong 
place...
Comment 4 Mike A. Harris 2001-05-16 12:37:23 EDT
No, thats the right one for 7.0...  Can you try the imap-2000-9 package
from Seawolf and see if that fixes it?

Thanks.
Comment 5 Mike A. Harris 2001-05-18 03:11:05 EDT
I just updated imap to version imap-2000c and it contains many fixes for
stuff like this.  The packages are available from:

ftp://people.redhat.com/mharris/testing

Does this solve it for you?  I cant get imapd to crash myself anymore.
Please let me know ASAP, as I'll be releasing errata soon.
Comment 6 Mike A. Harris 2001-05-18 20:14:58 EDT

*** This bug has been marked as a duplicate of 20858 ***

Note You need to log in before you can comment on or make changes to this bug.