Bug 408551 - All PCI express config registers are not accessible with RHEL5, with RHEL4 this works.
All PCI express config registers are not accessible with RHEL5, with RHEL4 th...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tony Camuso
Martin Jenner
: OtherQA
Depends On:
Blocks: RHEL5u2_relnotes
  Show dependency treegraph
 
Reported: 2007-12-03 07:03 EST by Bino J Sebastian
Modified: 2009-06-19 21:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:02:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (22.00 KB, application/octet-stream)
2008-02-20 13:02 EST, Bino J Sebastian
no flags Details

  None (edit)
Description Bino J Sebastian 2007-12-03 07:03:45 EST
Description of problem:
Standard config register size for a PCI device is 256 bytes. PCI-X and PCI
express devices have config registers upto 4096. On a ProLiant ML350 G4
running RHEL5 OS, system report only 256 byte config registers in sysfs tree.

# ls -l /sys/devices/pci0000:00/0000:00:06.0/0000*/config
-rw-r--r-- 1 root root 256 2007-12-03 03:43
/sys/devices/pci0000:00/0000:00:06.0/0000:10:00.0/config
-rw-r--r-- 1 root root 256 2007-12-03 03:43
/sys/devices/pci0000:00/0000:00:06.0/0000:10:00.1/config

#lspci
00:00.0 Host bridge: Intel Corporation E7520 Memory Controller Hub (rev 0c)
00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 0c)
00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 0c)
00:06.0 PCI bridge: Intel Corporation E7520 PCI Express Port C (rev 0c)
00:1c.0 PCI bridge: Intel Corporation 6300ESB 64-bit PCI-X Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 6300ESB USB Universal Host Controller
(rev 02)
00:1d.1 USB Controller: Intel Corporation 6300ESB USB Universal Host Controller
(rev 02)
00:1d.4 System peripheral: Intel Corporation 6300ESB Watchdog Timer (rev 02)
00:1d.5 PIC: Intel Corporation 6300ESB I/O Advanced Programmable Interrupt
Controller (rev 02)
00:1d.7 USB Controller: Intel Corporation 6300ESB USB2 Enhanced Host Controller
(rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 0a)
00:1f.0 ISA bridge: Intel Corporation 6300ESB LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 6300ESB PATA Storage Controller (rev 02)
01:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705_2 Gigabit
Ethernet (rev 03)
01:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
01:04.0 System peripheral: Compaq Computer Corporation Unknown device 00d7 (rev 01)
02:03.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 08)
02:03.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 08)
05:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A (rev 09)
05:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B (rev 09)
06:01.0 Fibre Channel: Emulex Corporation LP952 Fibre Channel Host Adapter (rev 01)
09:02.0 Fibre Channel: Emulex Corporation LP982 Fibre Channel Host Adapter (rev 01)
0d:00.0 Fibre Channel: Emulex Corporation Unknown device f015 (rev 01)
10:00.0 Fibre Channel: Emulex Corporation Unknown device f100 (rev 01)
10:00.1 Fibre Channel: Emulex Corporation Unknown device f100 (rev 01)


When I boot the same system with RHEL4, I am able to access 4096 bytes
of config registers of PCI express devices.

On some platforms, linux allows only access to 256 bytes of PCI config
registers even if PCI device support 4096 registers. This is due to properties
of PCI bridges in the system. I do not think this is the case here because
RHEL4 works correctly in this system.

Version-Release number of selected component (if applicable):
2.6.18-8

How reproducible:
100% reproducible.

Steps to Reproduce:
1. Boot RHEL5 on a ProLiant ML350 G4 with a PCI express device.
2. execute 'ls -l' comaand on the config sysfs file for the PCI express device
3.
  
Actual results:
'ls -l' command  report the file size as 256 byte

Expected results:
config sysfs file should be 4096 bytes for PCI express devices.

Additional info:
Comment 2 RHEL Product and Program Management 2008-01-18 15:37:51 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Don Zickus 2008-01-22 13:49:41 EST
in 2.6.18-72.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 6 Don Domingo 2008-02-06 23:44:36 EST
added to RHEL5.2 release notes under "Kernel-Related Updates":

<quote>
All PCI-X configuration registers (up to 4096 bytes) are now accessible.
</quote>

please advise if any further revisions are required. thanks!
Comment 7 Bino J Sebastian 2008-02-08 11:39:20 EST
We tested kernel-2.6.18-78.el5.x86_64.rpm kernel from
http://people.redhat.com/dzickus/el5. The issue is NOT resolved by
this kernel. 

2.6.18-72.el5 kernel is not present in http://people.redhat.com/dzickus/el5
now.

Please let us know how to download the RHEL5.2 kernel with this fix.
thanks,
-bino
Comment 8 Don Zickus 2008-02-08 13:37:27 EST
Tony, your patch covered a bunch of bugzillas.  Was this bugzilla supposed to be
one of them?
Comment 9 Tony Camuso 2008-02-08 13:41:55 EST
Yes, Don.

This BZ is covered by my patch.
Comment 10 Don Zickus 2008-02-08 13:47:45 EST
Tony, any thoughts why Bino may still have issues?
Comment 11 Tony Camuso 2008-02-08 14:36:55 EST
It may be a BIOS issue. Please email the output of dmidecode to tony.camuso@hp.com

I will investigate. 

I'll be away next week, so if I don't find an answer tonight or over the
weekend, it will have to wait until I get back.


Comment 12 Bino J Sebastian 2008-02-08 15:29:40 EST
Following is the dmidecode output.

# dmidecode 2.7
SMBIOS 2.3 present.
60 structures occupying 1596 bytes.
Table at 0x000EC000.

Handle 0x0000, DMI type 0, 20 bytes.
BIOS Information
	Vendor: HP
	Version: D17
	Release Date: 04/14/2005
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 4096 kB
	Characteristics:
		PCI is supported
		PNP is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		5.25"/360 KB floppy services are supported (int 13h)
		5.25"/1.2 MB floppy services are supported (int 13h)
		3.5"/720 KB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		CGA/mono video services are supported (int 10h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported

Handle 0x0100, DMI type 1, 25 bytes.
System Information
	Manufacturer: HP
	Product Name: ProLiant ML350 G4
	Version: Not Specified
	Serial Number: USM53000GE      
	UUID: 33333138-3930-5553-4D35-333030304745
	Wake-up Type: Power Switch

Handle 0x0300, DMI type 3, 17 bytes.
Chassis Information
	Manufacturer: HP
	Type: Tower
	Lock: Not Present
	Version: Not Specified
	Serial Number: USM53000GE      
	Asset Tag:                                 
	Boot-up State: Unknown
	Power Supply State: Unknown
	Thermal State: Unknown
	Security Status: Unknown
	OEM Information: 0x00000000

Handle 0x0400, DMI type 4, 32 bytes.
Processor Information
	Socket Designation: Proc 1
	Type: Central Processor
	Family: Xeon
	Manufacturer: Intel
	ID: 41 0F 00 00 FF FB EB BF
	Signature: Type 0, Family 15, Model 4, Stepping 1
	Flags:
		FPU (Floating-point unit on-chip)
		VME (Virtual mode extension)
		DE (Debugging extension)
		PSE (Page size extension)
		TSC (Time stamp counter)
		MSR (Model specific registers)
		PAE (Physical address extension)
		MCE (Machine check exception)
		CX8 (CMPXCHG8 instruction supported)
		APIC (On-chip APIC hardware supported)
		SEP (Fast system call)
		MTRR (Memory type range registers)
		PGE (Page global enable)
		MCA (Machine check architecture)
		CMOV (Conditional move instruction supported)
		PAT (Page attribute table)
		PSE-36 (36-bit page size extension)
		CLFSH (CLFLUSH instruction supported)
		DS (Debug store)
		ACPI (ACPI supported)
		MMX (MMX technology supported)
		FXSR (Fast floating-point save and restore)
		SSE (Streaming SIMD extensions)
		SSE2 (Streaming SIMD extensions 2)
		SS (Self-snoop)
		HTT (Hyper-threading technology)
		TM (Thermal monitor supported)
		PBE (Pending break enabled)
	Version: Not Specified
	Voltage: 1.4 V
	External Clock: 800 MHz
	Max Speed: 4800 MHz
	Current Speed: 3000 MHz
	Status: Populated, Enabled
	Upgrade: ZIF Socket
	L1 Cache Handle: 0x0710
	L2 Cache Handle: 0x0720
	L3 Cache Handle: 0x0730

Handle 0x0406, DMI type 4, 32 bytes.
Processor Information
	Socket Designation: Proc 2
	Type: Central Processor
	Family: Xeon
	Manufacturer: Intel
	ID: 41 0F 00 00 FF FB EB BF
	Signature: Type 0, Family 15, Model 4, Stepping 1
	Flags:
		FPU (Floating-point unit on-chip)
		VME (Virtual mode extension)
		DE (Debugging extension)
		PSE (Page size extension)
		TSC (Time stamp counter)
		MSR (Model specific registers)
		PAE (Physical address extension)
		MCE (Machine check exception)
		CX8 (CMPXCHG8 instruction supported)
		APIC (On-chip APIC hardware supported)
		SEP (Fast system call)
		MTRR (Memory type range registers)
		PGE (Page global enable)
		MCA (Machine check architecture)
		CMOV (Conditional move instruction supported)
		PAT (Page attribute table)
		PSE-36 (36-bit page size extension)
		CLFSH (CLFLUSH instruction supported)
		DS (Debug store)
		ACPI (ACPI supported)
		MMX (MMX technology supported)
		FXSR (Fast floating-point save and restore)
		SSE (Streaming SIMD extensions)
		SSE2 (Streaming SIMD extensions 2)
		SS (Self-snoop)
		HTT (Hyper-threading technology)
		TM (Thermal monitor supported)
		PBE (Pending break enabled)
	Version: Not Specified
	Voltage: 1.4 V
	External Clock: 800 MHz
	Max Speed: 4800 MHz
	Current Speed: 3000 MHz
	Status: Populated, Idle
	Upgrade: ZIF Socket
	L1 Cache Handle: 0x0716
	L2 Cache Handle: 0x0726
	L3 Cache Handle: 0x0736

Handle 0x0710, DMI type 7, 19 bytes.
Cache Information
	Socket Designation: Processor 1 Internal L1 Cache
	Configuration: Enabled, Not Socketed, Level 1
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 16 KB
	Maximum Size: 32 KB
	Supported SRAM Types:
		Burst
	Installed SRAM Type: Burst
	Speed: Unknown
	Error Correction Type: Unknown
	System Type: Unknown
	Associativity: 4-way Set-associative

Handle 0x0716, DMI type 7, 19 bytes.
Cache Information
	Socket Designation: Processor 2 Internal L1 Cache
	Configuration: Enabled, Not Socketed, Level 1
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 16 KB
	Maximum Size: 32 KB
	Supported SRAM Types:
		Burst
	Installed SRAM Type: Burst
	Speed: Unknown
	Error Correction Type: Unknown
	System Type: Unknown
	Associativity: 4-way Set-associative

Handle 0x0720, DMI type 7, 19 bytes.
Cache Information
	Socket Designation: Processor 1 Internal L2 Cache
	Configuration: Enabled, Not Socketed, Level 2
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 1024 KB
	Maximum Size: 2048 KB
	Supported SRAM Types:
		Burst
	Installed SRAM Type: Burst
	Speed: Unknown
	Error Correction Type: Unknown
	System Type: Unknown
	Associativity: Other

Handle 0x0726, DMI type 7, 19 bytes.
Cache Information
	Socket Designation: Processor 2 Internal L2 Cache
	Configuration: Enabled, Not Socketed, Level 2
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 1024 KB
	Maximum Size: 2048 KB
	Supported SRAM Types:
		Burst
	Installed SRAM Type: Burst
	Speed: Unknown
	Error Correction Type: Unknown
	System Type: Unknown
	Associativity: Other

Handle 0x0730, DMI type 7, 19 bytes.
Cache Information
	Socket Designation: Processor 1 Internal L3 Cache
	Configuration: Enabled, Not Socketed, Level 3
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 0 KB
	Maximum Size: 1024 KB
	Supported SRAM Types:
		Burst
	Installed SRAM Type: Burst
	Speed: Unknown
	Error Correction Type: Unknown
	System Type: Unknown
	Associativity: Other

Handle 0x0736, DMI type 7, 19 bytes.
Cache Information
	Socket Designation: Processor 2 Internal L3 Cache
	Configuration: Enabled, Not Socketed, Level 3
	Operational Mode: Write Back
	Location: Internal
	Installed Size: 0 KB
	Maximum Size: 1024 KB
	Supported SRAM Types:
		Burst
	Installed SRAM Type: Burst
	Speed: Unknown
	Error Correction Type: Unknown
	System Type: Unknown
	Associativity: Other

Handle 0x0801, DMI type 8, 9 bytes.
Port Connector Information
	Internal Reference Designator: J48
	Internal Connector Type: Access Bus (USB)
	External Reference Designator: USB Port 1
	External Connector Type: Access Bus (USB)
	Port Type: USB

Handle 0x0802, DMI type 8, 9 bytes.
Port Connector Information
	Internal Reference Designator: J48
	Internal Connector Type: Access Bus (USB)
	External Reference Designator: USB Port 2
	External Connector Type: Access Bus (USB)
	Port Type: USB

Handle 0x0901, DMI type 9, 13 bytes.
System Slot Information
	Designation: PCI-E Slot 1
	Type: x4 PCI Express
	Current Usage: In Use
	Length: Other
	Characteristics:
		3.3 V is provided
		PME signal is supported

Handle 0x0902, DMI type 9, 13 bytes.
System Slot Information
	Designation: PCI-E Slot 2
	Type: x8 PCI Express
	Current Usage: Available
	Length: Other
	Characteristics:
		3.3 V is provided
		PME signal is supported

Handle 0x0903, DMI type 9, 13 bytes.
System Slot Information
	Designation: PCI Slot 3  
	Type: 64-bit PCI-X
	Current Usage: In Use
	Length: Long
	ID: 3
	Characteristics:
		3.3 V is provided
		PME signal is supported

Handle 0x0904, DMI type 9, 13 bytes.
System Slot Information
	Designation: PCI Slot 4  
	Type: 64-bit PCI-X
	Current Usage: Available
	Length: Long
	ID: 4
	Characteristics:
		3.3 V is provided
		PME signal is supported

Handle 0x0905, DMI type 9, 13 bytes.
System Slot Information
	Designation: PCI Slot 5  
	Type: 64-bit PCI-X
	Current Usage: In Use
	Length: Long
	ID: 5
	Characteristics:
		3.3 V is provided
		PME signal is supported

Handle 0x0906, DMI type 9, 13 bytes.
System Slot Information
	Designation: PCI Slot 6  
	Type: 64-bit PCI-X
	Current Usage: Available
	Length: Long
	ID: 6
	Characteristics:
		3.3 V is provided
		PME signal is supported

Handle 0x0B00, DMI type 11, 5 bytes.
OEM Strings
	String 1: Product ID: 331890-001      

Handle 0x1000, DMI type 16, 15 bytes.
Physical Memory Array
	Location: System Board Or Motherboard
	Use: System Memory
	Error Correction Type: Single-bit ECC
	Maximum Capacity: 8 GB
	Error Information Handle: Not Provided
	Number Of Devices: 4

Handle 0x1100, DMI type 17, 23 bytes.
Memory Device
	Array Handle: 0x1000
	Error Information Handle: Not Provided
	Total Width: 72 bits
	Data Width: 64 bits
	Size: 512 MB
	Form Factor: DIMM
	Set: 1
	Locator: DIMM 01
	Bank Locator: Not Specified
	Type: DDR
	Type Detail: Synchronous
	Speed: 333 MHz (3.0 ns)

Handle 0x1101, DMI type 17, 23 bytes.
Memory Device
	Array Handle: 0x1000
	Error Information Handle: Not Provided
	Total Width: 72 bits
	Data Width: 64 bits
	Size: 512 MB
	Form Factor: DIMM
	Set: 1
	Locator: DIMM 02
	Bank Locator: Not Specified
	Type: DDR
	Type Detail: Synchronous
	Speed: 333 MHz (3.0 ns)

Handle 0x1102, DMI type 17, 23 bytes.
Memory Device
	Array Handle: 0x1000
	Error Information Handle: Not Provided
	Total Width: 72 bits
	Data Width: 64 bits
	Size: No Module Installed
	Form Factor: DIMM
	Set: 2
	Locator: DIMM 03
	Bank Locator: Not Specified
	Type: DDR
	Type Detail: Synchronous
	Speed: 333 MHz (3.0 ns)

Handle 0x1103, DMI type 17, 23 bytes.
Memory Device
	Array Handle: 0x1000
	Error Information Handle: Not Provided
	Total Width: 72 bits
	Data Width: 64 bits
	Size: No Module Installed
	Form Factor: DIMM
	Set: 2
	Locator: DIMM 04
	Bank Locator: Not Specified
	Type: DDR
	Type Detail: Synchronous
	Speed: 333 MHz (3.0 ns)

Handle 0x1300, DMI type 19, 15 bytes.
Memory Array Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x0003FFFFFFF
	Range Size: 1 GB
	Physical Array Handle: 0x1000
	Partition Width: 0

Handle 0x1400, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x0003FFFFFFF
	Range Size: 1 GB
	Physical Device Handle: 0x1100
	Memory Array Mapped Address Handle: 0x1300
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: Unknown

Handle 0x1401, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x0003FFFFFFF
	Range Size: 1 GB
	Physical Device Handle: 0x1101
	Memory Array Mapped Address Handle: 0x1300
	Partition Row Position: 1
	Interleave Position: 2
	Interleaved Data Depth: Unknown

Handle 0x1402, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x1102
	Memory Array Mapped Address Handle: 0x1300
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: Unknown

Handle 0x1403, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x1103
	Memory Array Mapped Address Handle: 0x1300
	Partition Row Position: 1
	Interleave Position: 2
	Interleaved Data Depth: Unknown

Handle 0x1450, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: Unknown

Handle 0x1451, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 2
	Interleaved Data Depth: Unknown

Handle 0x1452, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: Unknown

Handle 0x1453, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 2
	Interleaved Data Depth: Unknown

Handle 0x1460, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: Unknown

Handle 0x1461, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 2
	Interleaved Data Depth: Unknown

Handle 0x1462, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 1
	Interleaved Data Depth: Unknown

Handle 0x1463, DMI type 20, 19 bytes.
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000000003FF
	Range Size: 1 kB
	Physical Device Handle: 0x0000
	Memory Array Mapped Address Handle: 0x0000
	Partition Row Position: 1
	Interleave Position: 2
	Interleaved Data Depth: Unknown

Handle 0x2000, DMI type 32, 11 bytes.
System Boot Information
	Status: No errors detected

Handle 0xC100, DMI type 193, 7 bytes.
OEM-specific Type
	Header and Data:
		C1 07 00 C1 01 01 02
	Strings:
		04/14/2005
		03/31/2004

Handle 0xC200, DMI type 194, 5 bytes.
OEM-specific Type
	Header and Data:
		C2 05 00 C2 0D

Handle 0xC300, DMI type 195, 5 bytes.
OEM-specific Type
	Header and Data:
		C3 05 00 C3 01
	Strings:
		$0E11074C

Handle 0xC400, DMI type 196, 5 bytes.
OEM-specific Type
	Header and Data:
		C4 05 00 C4 00

Handle 0xC500, DMI type 197, 10 bytes.
OEM-specific Type
	Header and Data:
		C5 0A 00 C5 00 04 00 01 FF 01

Handle 0xC506, DMI type 197, 10 bytes.
OEM-specific Type
	Header and Data:
		C5 0A 06 C5 06 04 06 00 FF 02

Handle 0xD300, DMI type 211, 7 bytes.
OEM-specific Type
	Header and Data:
		D3 07 00 D3 00 04 44

Handle 0xD306, DMI type 211, 7 bytes.
OEM-specific Type
	Header and Data:
		D3 07 06 D3 06 04 44

Handle 0xC600, DMI type 198, 10 bytes.
OEM-specific Type
	Header and Data:
		C6 0A 00 C6 17 00 00 01 3C 00

Handle 0xC700, DMI type 199, 28 bytes.
OEM-specific Type
	Header and Data:
		C7 1C 00 C7 12 00 00 00 04 20 22 11 41 0F 00 00
		14 00 00 00 04 20 04 11 34 0F 00 00

Handle 0xCA00, DMI type 202, 8 bytes.
OEM-specific Type
	Header and Data:
		CA 08 00 CA 00 11 FF 01

Handle 0xCA01, DMI type 202, 8 bytes.
OEM-specific Type
	Header and Data:
		CA 08 01 CA 01 11 FF 02

Handle 0xCA02, DMI type 202, 8 bytes.
OEM-specific Type
	Header and Data:
		CA 08 02 CA 02 11 FF 03

Handle 0xCA03, DMI type 202, 8 bytes.
OEM-specific Type
	Header and Data:
		CA 08 03 CA 03 11 FF 04

Handle 0xCD00, DMI type 205, 22 bytes.
OEM-specific Type
	Header and Data:
		CD 16 00 CD 01 01 46 41 54 78 00 00 D3 FF 00 00
		00 00 00 80 05 00

Handle 0xD100, DMI type 209, 12 bytes.
OEM-specific Type
	Header and Data:
		D1 0C 00 D1 10 01 00 14 38 4E EA 91

Handle 0xD400, DMI type 212, 24 bytes.
OEM-specific Type
	Header and Data:
		D4 18 00 D4 24 43 52 55 00 00 F7 FF 00 00 00 00
		00 40 00 00 00 00 00 00

Handle 0xD401, DMI type 212, 24 bytes.
OEM-specific Type
	Header and Data:
		D4 18 01 D4 24 53 48 46 00 C0 F8 FF 00 00 00 00
		00 40 00 00 00 00 00 00

Handle 0xD500, DMI type 213, 28 bytes.
OEM-specific Type
	Header and Data:
		D5 1C 00 D5 00 00 36 00 00 00 BF 1F 00 00 46 00
		00 00 00 00 00 00 00 00 00 00 00 00

Handle 0xD600, DMI type 214, 44 bytes.
OEM-specific Type
	Header and Data:
		D6 2C 00 D6 31 31 00 02 0E 20 00 00 13 20 00 00
		00 60 00 00 00 20 00 00 02 20 00 00 04 20 00 00
		06 20 00 00 0C 20 00 00 08 20 00 00

Handle 0x7F00, DMI type 127, 4 bytes.
End Of Table

Comment 13 Bino J Sebastian 2008-02-08 16:34:18 EST
With RHEL4 kernel all PCI registers are accessible on this system with same BIOS.
So, I assume the issue is outside the BIOS.
Comment 14 Tony Camuso 2008-02-20 07:58:16 EST
It may still be the BIOS.

I think the kernel in RHEL 5 does some MMCONF validation checks in the BIOS that
the RHEL 4 kernel does not do. 

Let me investigate more. 
Comment 15 Tony Camuso 2008-02-20 08:15:55 EST
Bino, 

Can you post a dump of dmesg for us? This will help us determine whether the
system is using MMCONF or not. 

Comment 16 Tony Camuso 2008-02-20 09:36:41 EST
Bino, 

Can you post a dump of dmesg for us? This will help us determine whether the
system is using MMCONF or not. 

Comment 17 Bino J Sebastian 2008-02-20 13:02:31 EST
Created attachment 295434 [details]
dmesg output

dmesg output is attached.
Comment 18 Tony Camuso 2008-02-20 16:18:45 EST
The RHEL5 kernel does an additional validation test of MMCONF space before using
it. If the BIOS does not have the correct information for MMCONF in e820, then
the RHEL 5 kernel constrains PCI config accesses to PortIO.

Don suggested a boot command that would circumvent this test in RHEL5 and allow
 MMCONF to work. I need to work out some details about network boot before I can
devise a patch. 
Comment 19 John Poelstra 2008-03-20 22:36:59 EDT
reading the comments above, it does not appear this issues is fixed
Comment 20 Tony Camuso 2008-03-21 07:31:19 EDT
No, this issue is not fixed, yet. 

This is a BIOS problem, not a kernel problem, though there is a workaround we
can implement in the kernel using a boot command. This workaround has not yet
been impmlemented. 
Comment 21 Tony Camuso 2008-03-21 10:21:28 EDT
Update:

May have new BIOS today ...
Comment 22 Tony Camuso 2008-03-21 11:27:38 EDT
Please have the customer try the new BIOS. 


SP38749.EXE and CP008955.SCEXE - Softpaq and Online Rom Flash Component for
ProLiant ML350 G4 v2008.02.23 are now on ftp site. (SINGLE POINT for Emulex).

ftp://ftp.hp.com/pub/softlib2/software1/pubsw-windows/p1007532092/v46402 SP38749.EXE
UniqueID: f4137258ba54462b80b99271a39a0bcf 

ftp://ftp.hp.com/pub/softlib2/software1/sc-linux-fw-sys/p1936989030/v46400
CP008955.scexe
UniqueID: a753d9ce500c46b6985de434137cb80b 

Comment 23 Tony Camuso 2008-03-26 08:13:12 EDT
Bino, 

Please try the new BIOS and let us know if it fixes the problem.


Comment 24 Peter Martuccelli 2008-03-27 10:07:37 EDT
We are past the time for submitting a patch for R5.2, if not a BIOS issue then
revisit in R5.3.
Comment 25 Tony Camuso 2008-03-27 10:15:40 EDT
I am certain that is a BIOS issue. I believe I have proven that by
commenting-out the call to test the e820 area in BIOS for MMCONF support. When
that call is omitted, the extended PCI space is visible. 

Comment 26 Don Domingo 2008-04-01 22:14:01 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don
Comment 28 errata-xmlrpc 2008-05-21 11:02:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.