Bug 408651 - Revive compat-gcc-32-c++
Revive compat-gcc-32-c++
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compat-gcc-32 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 09:13 EST by Denis Leroy
Modified: 2007-12-06 18:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 08:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2007-12-03 09:13:53 EST
Would it be possible to revice compat-gcc-32-c++ ?

I'm not sure why it was obsoleted in the first place. While I don't think
there's much demand for gcc32, g++32 on the other hand is extremely useful
because it's the last version of g++ that uses libstdc++.so.5. Currently it is
impossible in Fedora to link with libraries that depend on libstdc++.so.5 (or is
there another trick?). I've carried around an old compat-gcc-32 SRPM, but it
gets tougher and tougher to maintain.

thanks :-)
Comment 1 Jakub Jelinek 2007-12-06 08:09:22 EST
Because we only want to support one full compat compiler.
If you have software which can't be built even with the now prehistoric G++ 3.4,
then you simply should spend time fixing that up, not carying forever ever
increasing set of compat compilers.
Comment 2 Denis Leroy 2007-12-06 17:15:46 EST
Actually if one needs to link with libstdc++.so.5, it's precisely because you
don't have the source code anymore. Not because it's closed source, but simply
because you don't have access to the source code anymore, or lost the code or
whatnot. You'd be surprised how often I've needed g++32 here at work in the past
couple of years. It you were to maintain one and only need compat-g++, it would
be g++ 3.2, not 3.4, precisely because of the ABI compatibility issue.

I'm not sure who you mean by "We" ? I'll go ahead and submit my own
compat-gcc-32-c++ RPM, I don't mind maintaing it. I'll only need you to remove
the Obsolete: from your packages after it passes review. Thx.
Comment 3 Denis Leroy 2007-12-06 18:44:33 EST
Sorry I didn't like the way I wrote that last paragraph in my last post. I'm
assuming the reason you maintain only one compat package is because of the work
required to do so ? how much work would you expect would go into maintaining
compat-gcc-32-c++ ?

Note You need to log in before you can comment on or make changes to this bug.