Bug 408681 - PostgreSQL ODBC driver does not work
PostgreSQL ODBC driver does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: postgresql-odbc (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 09:35 EST by Tom Hughes
Modified: 2013-07-02 23:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: 08.02.0500-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 15:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix CONNLOCK macros (612 bytes, patch)
2007-12-03 09:38 EST, Tom Hughes
no flags Details | Diff

  None (edit)
Description Tom Hughes 2007-12-03 09:35:37 EST
Description of problem:

The PostgreSQL ODBC driver does work as it contains symbols that cannot be
resolved so cannot be loaded.

Version-Release number of selected component (if applicable):

postgresql-odbc-08.02.0200-2.fc8.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Define a PostgreSQL ODBC data source
2. Try and connect to it
  
Actual results:

Driver fails to load:

dellow [~] % isql usage     
isql: symbol lookup error: /usr/lib64/psqlodbc.so: undefined symbol: INIT_CONNLOCK

Expected results:

Driver loads.

Additional info:
Comment 1 Tom Hughes 2007-12-03 09:38:00 EST
Created attachment 275711 [details]
Patch to fix CONNLOCK macros

The problem (which looks like it has come from upstream) is that some of the
CONNLOCK macros are not properly defined which not building in thread safe
mode. This patch fixes that.

The alternative fix is to build it in thread safe mode by configuring with
--enable-pthreads.
Comment 2 Tom Lane 2007-12-03 11:34:14 EST
This is fixed in rawhide (08.02.0500) so I suppose back-porting that is the thing to do.
Comment 3 Fedora Update System 2007-12-06 15:46:28 EST
postgresql-odbc-08.02.0500-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-12-06 15:49:22 EST
postgresql-odbc-08.02.0500-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.