Bug 408731 - __USE_STRING_INLINES and string.h with _FORTIFY_SOURCE
__USE_STRING_INLINES and string.h with _FORTIFY_SOURCE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 10:24 EST by Mamoru TASAKA
Modified: 2007-12-17 01:13 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 01:13:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2007-12-03 10:24:53 EST
Description of problem:
Rebuilding jfbterm (,which I maintain on Fedora) fails
on F-8 and rawhide.
http://koji.fedoraproject.org/koji/taskinfo?taskID=271418

After some investigation, the code failing to build could
be shortened as below:
TEST-memmove.c :
----------------------------------------------------------
#define __USE_STRING_INLINES
#include        <string.h>

int main(){
	return 0;
}
----------------------------------------------------------
$ gcc -O2 -Wp,-D_FORTIFY_SOURCE=2 -o TEST-memmove TEST-memmove.c
In file included from /usr/include/string.h:428,
                 from TEST-memmove.c:2:
/usr/include/bits/string3.h:58: error: redefinition of ‘memmove’

Is this expected?

Version-Release number of selected component (if applicable):
glibc-2.7-2
gcc-4.1.2-33 (F-8), gcc-4.1.2-35 (rawhide)

How reproducible:
100%

Additional info:
This code doesn't fail on F-7.
Comment 1 Mamoru TASAKA 2007-12-17 01:13:56 EST
Seems to be fixed in 2.7.90-1, thanks.

Note You need to log in before you can comment on or make changes to this bug.