Bug 408761 - Update Bugzilla/DB/Schema.pm to add in changes from rh_bugzilla_2_18 schema
Update Bugzilla/DB/Schema.pm to add in changes from rh_bugzilla_2_18 schema
Status: CLOSED DUPLICATE of bug 420611
Product: Bugzilla
Classification: Community
Component: Database (Show other bugs)
3.2
All Linux
high Severity low (vote)
: ---
: ---
Assigned To: Tony Fu
https://engineering.redhat.com/rt3/Ti...
:
Depends On:
Blocks: RHBZ30UpgradeTracker
  Show dependency treegraph
 
Reported: 2007-12-03 10:44 EST by David Lawrence
Modified: 2013-06-24 00:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 00:00:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HTML file comparing 3.0 schema with RH 2.18 schema (147.36 KB, text/html)
2007-12-03 10:44 EST, David Lawrence
no flags Details

  None (edit)
Description David Lawrence 2007-12-03 10:44:19 EST
Description of problem:
We need to add tables/columns current in rh_bugzilla_2_18 that are being
actively used by Red Hat. This will allow a clean migration of our current
snapshots to a fresh 3.0 database created by checksetup.pl.

We can use Noura's output from her db schema script to determine that needs to be 
moved over.

The critical things we need to look at when migrating our data are:

1. The tables/columns that are in purple will need to be added to the
Bugzilla/DB/Schema.pm file.
2. The columns that are in yellow that have a NOT NULL constraint will need to
be set to NULL when we import the data. Then we will need to go back and set 
the values to something appropriate and re-instate the NOT NULL restriction. The
alternative would be to somehow insert appropriate values for the new columns
when the data is imported. That may prove to be more difficult to implement.
3. The new tables marked with yellow may need some default list to be populated
so cannot be left empty when the data base is created. So we may need to alter
checksetup.pl to auto-populate the new tables but leave the old ones empty for
our imported data.

Attaching the output file containing the comparison.
Comment 1 David Lawrence 2007-12-03 10:44:19 EST
Created attachment 275761 [details]
HTML file comparing 3.0 schema with RH 2.18 schema
Comment 2 David Lawrence 2007-12-12 00:00:56 EST

*** This bug has been marked as a duplicate of 420611 ***

Note You need to log in before you can comment on or make changes to this bug.