Bug 408881 - gnome-session slows all app startup after suspend/resume
gnome-session slows all app startup after suspend/resume
Status: CLOSED DUPLICATE of bug 408921
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-03 12:17 EST by Jason Merrill
Modified: 2007-12-03 12:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-03 12:35:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jason Merrill 2007-12-03 12:17:05 EST
Description of problem:

After a suspend/resume cycle, startup of X applications becomes much slower; it
takes 15+ seconds to start a program that started up in less than a second
before the suspend.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Suspend
2. Resume
3. strace xterm (or whatever)
Actual results:

strace shows that xterm startup blocks for 15+ seconds trying to read a response
from gnome-session.

Expected results:

No user-noticeable blocking.

Additional info:

I'm currently using a Thinkpad T61, but I noticed the same behavior in Fedora 7
on a Thinkpad T41.
Comment 1 Jason Merrill 2007-12-03 12:28:17 EST
Adding my hostname to the line in /etc/hosts fixed the slowdown;
apparently it happens because DNS is trying and failing to resolve my hostname.
Comment 2 Jason Merrill 2007-12-03 12:35:50 EST

*** This bug has been marked as a duplicate of 408921 ***

Note You need to log in before you can comment on or make changes to this bug.