Bug 408961 - Evolution hangs when viewing reminder e-mail from Google Calendar
Evolution hangs when viewing reminder e-mail from Google Calendar
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 12:49 EST by Troy Carter
Modified: 2008-01-17 12:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 12:58:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mail message output from evolution using "save as" (8.14 KB, application/octet-stream)
2007-12-03 15:07 EST, Troy Carter
no flags Details
Output from gdb "thread apply all bt" when attached to frozen evolution process (5.05 KB, text/plain)
2007-12-03 15:11 EST, Troy Carter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 501298 None None None Never

  None (edit)
Description Troy Carter 2007-12-03 12:49:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
Evolution will freeze (but not crash) when viewing reminder e-mails from Google Calendar.  If I kill the application (command line or using force quit) and restart, the hang will continue.  I have to use another mail client to delete the reminder e-mail from my inbox before evolution will start again successfully.  This happens every time I try to view a new Google Calendar reminder e-mail, so is not specific to a particular reminder.



Version-Release number of selected component (if applicable):
evolution-2.12.1-3.fc8

How reproducible:
Always


Steps to Reproduce:
1. Get new google calendar reminder e-mail in evolution inbox
2. Click on e-mail to view message
3. 

Actual Results:
Evolution becomes unresponsive, but does not crash (I have waited for quite a while (~10minutes) to see if it will recover, but it does not)

Expected Results:
Message should have displayed without hang

Additional info:
Here is source from a Google Calendar reminder e-mail that caused a hang:

Delivered-To: tacarter@gmail.com
Received: by 10.64.76.6 with SMTP id y6cs136994qba;
        Mon, 3 Dec 2007 09:20:12 -0800 (PST)
Received: by 10.86.33.10 with SMTP id g10mr9227916fgg.1196702411534;
        Mon, 03 Dec 2007 09:20:11 -0800 (PST)
Return-Path: <3yTpURxUKCJ8B9KDMC9Q-MNSHEHB9SHNMFNNFKD.BNLS9B9QSDQFL9HK.BNL@calendar-server.bounces.google.com>
Received: from py-out-f140.google.com (py-out-f140.google.com [64.233.166.140])
        by mx.google.com with ESMTP id e11si6367654fga.2007.12.03.09.20.09;
        Mon, 03 Dec 2007 09:20:11 -0800 (PST)
Received-SPF: pass (google.com: domain of 3yTpURxUKCJ8B9KDMC9Q-MNSHEHB9SHNMFNNFKD.BNLS9B9QSDQFL9HK.BNL@calendar-server.bounces.google.com designates 64.233.166.140 as permitted sender) client-ip=64.233.166.140;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of 3yTpURxUKCJ8B9KDMC9Q-MNSHEHB9SHNMFNNFKD.BNLS9B9QSDQFL9HK.BNL@calendar-server.bounces.google.com designates 64.233.166.140 as permitted sender) smtp.mail=3yTpURxUKCJ8B9KDMC9Q-MNSHEHB9SHNMFNNFKD.BNLS9B9QSDQFL9HK.BNL@calendar-server.bounces.google.com; dkim=pass (test mode) header.i=@google.com
Received: by py-out-f140.google.com with SMTP id v12so538694pyh
        for <tacarter@gmail.com>; Mon, 03 Dec 2007 09:20:09 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=google.com; s=beta;
        h=domainkey-signature:mime-version:message-id:date:reply-to:received:subject:from:to:content-type;
        bh=Xapk5Mqg5aGUe056xON1MisXz9EwTUODbhBhz8A6u40=;
        b=RqJfEIBzeEX/roTLZZwf8zbPwm/5wIhUlYNfZHSFO2TCTpQNH51+RiwgAM9rx8PnWe5E4j6PRPN4RFUXc5p91A==
DomainKey-Signature: a=rsa-sha1; c=nofws;
        d=google.com; s=beta;
        h=mime-version:message-id:date:reply-to:received:subject:from:to:content-type;
        b=PQyTrkdC6XHlkQnKhcQ8NBVICDf0uK9XE9uk7IZumVBvyvNr+0hnp8JVHdylqt7E+jb0sF55X7YEHjP9Tm12NQ==
MIME-Version: 1.0
Message-ID: <00163600ca7f044064fe0a8718133391@google.com>
Date: Mon, 03 Dec 2007 09:20:09 -0800
Reply-To: Troy Carter <tacarter@gmail.com>
Received: by 10.35.59.5 with SMTP id m5mr6911551pyk.1196702409852; Mon, 03 Dec 
	2007 09:20:09 -0800 (PST)
Subject: [Reminder] Meet with Catherine Allen @ Mon Dec 3 9:30am - 10:30am 
	(Troy Carter: Work)
From: Google Calendar <calendar-notification@google.com>
To: Troy Carter <tacarter@gmail.com>
Content-Type: multipart/mixed; boundary=00163600ca7f044064fe0a86f65f1dfc

--00163600ca7f044064fe0a86f65f1dfc
Content-Type: multipart/alternative; 
	boundary=00163600ca7f044064fe0a86f35f1dfb

--00163600ca7f044064fe0a86f35f1dfb
Content-Type: text/plain; charset=ISO-8859-1; Format=Flowed
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

Troy Carter, this is a reminder for

Title: Meet with Catherine Allen
Time: Mon Dec 3 9:30am - 10:30am (Pacific Time)
Calendar: Troy Carter: Work

You can view this event at http://www.google.com/calendar/event?action=VIEW&eid=MGg0YnIwODlnNWI5a3J1YzdnYTFxOGFlOWcgdGFjYXJ0ZXJAbQ&tok=MTgjdGFjYXJ0ZXJAZ21haWwuY29tNjc0ZWIzYmRiZDY5Zjc0OGI2ZjlmNTVlMmU2NDJiNDg3YzFmNjllMA&ctz=America%2FLos_Angeles&hl=en

You can also view your calendar at http://www.google.com/calendar/

You are receiving this email at the account tacarter@gmail.com because 
you are subscribed for reminders on calendar Troy Carter: Work.

To stop receiving these notifications, please log in to 
http://www.google.com/calendar/ and change your notification settings 
for this calendar.
--00163600ca7f044064fe0a86f35f1dfb
Content-Type: text/html; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

<div style="padding:10px 7px; font-size:12px; line-height:1.4 font-family:Arial,Sans-serif; text-align:center;"><div><a href="http://www.google.com/calendar/"><img style="border-width:0" src="http://www.google.com/calendar/images/blue_beta_en.gif" alt="Google Calendar"></a></div>
<div style="width:370px; background:#D2E6D2; border-style:solid;       border-color:#ccc; border-width:1px 1px 0 1px; padding:15px 15px 5px 15px;       margin:0 auto"><p style="margin:0;color:#0">Troy Carter,
this is a reminder for</p>
<h2 style="margin:5px 0; font-size:18px; line-height:1.4;color:#0">Meet with Catherine Allen</h2>
<p style="margin:0 0 .5em;"><span style="color:#0">Mon Dec 3 9:30am - 10:30am</span>
<br>
<span style="color:#676;">(Pacific Time)</span>
<br>
<span style="color:#0"></span>
<br>
<span style="color:#0">Calendar:
Troy Carter: Work</span></p>
<p style="margin:0 0 1em;color:#0;white-space:pre"><a href="http://www.google.com/calendar/event?action=VIEW&amp;eid=MGg0YnIwODlnNWI5a3J1YzdnYTFxOGFlOWcgdGFjYXJ0ZXJAbQ&amp;tok=MTgjdGFjYXJ0ZXJAZ21haWwuY29tNjc0ZWIzYmRiZDY5Zjc0OGI2ZjlmNTVlMmU2NDJiNDg3YzFmNjllMA&amp;ctz=America%2FLos_Angeles&amp;hl=en">More event details&raquo;</a></p>
</div>
<div><img src="http://www.google.com/calendar/images/envelope.gif" style="background:#D2E6D2; width:420px height:95px" alt=""></div><p style="margin:-15px 0 0;"><a href="http://www.google.com/calendar/">View your calendar&raquo;</a></p>
<p style="color:#676;">You are receiving this email at the account tacarter@gmail.com because you are subscribed for reminders on calendar Troy Carter: Work.</p><p style="color:#676;">To stop receiving these notifications, please log in to http://www.google.com/calendar/ and change your notification settings for this calendar.</p></div>
--00163600ca7f044064fe0a86f35f1dfb
Content-Type: text/calendar; charset=ISO-8859-1; method=REQUEST
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

BEGIN:VCALENDAR
PRODID:-//Google Inc//Google Calendar 70.9054//EN
VERSION:2.0
CALSCALE:GREGORIAN
METHOD:REQUEST
BEGIN:VEVENT
DTSTART:20071203T173000Z
DTEND:20071203T183000Z
DTSTAMP:20071203T172009Z
UID:0h4br089g5b9kruc7ga1q8ae9g@google.com
CLASS:PRIVATE
CREATED:20071128T213829Z
DESCRIPTION:View your event at http://www.google.com/calendar/event?action=
 VIEW&eid=MGg0YnIwODlnNWI5a3J1YzdnYTFxOGFlOWcgdGFjYXJ0ZXJAbQ&tok=MTgjdGFjYXJ
 0ZXJAZ21haWwuY29tNjc0ZWIzYmRiZDY5Zjc0OGI2ZjlmNTVlMmU2NDJiNDg3YzFmNjllMA&ctz
 =America%2FLos_Angeles&hl=en.
LAST-MODIFIED:20071128T213829Z
SEQUENCE:0
STATUS:CONFIRMED
SUMMARY:Meet with Catherine Allen
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR
--00163600ca7f044064fe0a86f35f1dfb--
--00163600ca7f044064fe0a86f65f1dfc
Content-Type: application/ics; name="invite.ics"
Content-Disposition: attachment; filename="invite.ics"
Content-Transfer-Encoding: 7bit

BEGIN:VCALENDAR
PRODID:-//Google Inc//Google Calendar 70.9054//EN
VERSION:2.0
CALSCALE:GREGORIAN
METHOD:REQUEST
BEGIN:VEVENT
DTSTART:20071203T173000Z
DTEND:20071203T183000Z
DTSTAMP:20071203T172009Z
UID:0h4br089g5b9kruc7ga1q8ae9g@google.com
CLASS:PRIVATE
CREATED:20071128T213829Z
DESCRIPTION:View your event at http://www.google.com/calendar/event?action=
 VIEW&eid=MGg0YnIwODlnNWI5a3J1YzdnYTFxOGFlOWcgdGFjYXJ0ZXJAbQ&tok=MTgjdGFjYXJ
 0ZXJAZ21haWwuY29tNjc0ZWIzYmRiZDY5Zjc0OGI2ZjlmNTVlMmU2NDJiNDg3YzFmNjllMA&ctz
 =America%2FLos_Angeles&hl=en.
LAST-MODIFIED:20071128T213829Z
SEQUENCE:0
STATUS:CONFIRMED
SUMMARY:Meet with Catherine Allen
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR
--00163600ca7f044064fe0a86f65f1dfc--
Comment 1 Milan Crha 2007-12-03 14:33:48 EST
Thanks for report with data. I tried it but it works for me. It has been "fixed"
by pasting to the report or there is other issue. I would like to ask you few
things:
a) Could you install debug info packages for evolution, evolution-data-server
and gtkhtml3 and when it get stuck, please attach gdb to evolution process and
do "thread apply all bt" command in gdb and attach here the output.

b) Could you attach here the offending email from evolution, please? You can run
evolution with parameter --disable-preview parameter, which should help here.
Then you can select the message and right click over it and do Save As...

c) What is your setup in Edit->Preferences->Mail Preferences, tab "HTML
Messages", section Loading Images and Plain Text Mode?

d) What kind of calendars do you have setup in Evolution? Maybe it has some
troubles to open particular calendar (it will be shown in output from a) probably).

Thanks in advance.
Comment 2 Troy Carter 2007-12-03 15:07:42 EST
Created attachment 276071 [details]
Mail message output from evolution using "save as"
Comment 3 Troy Carter 2007-12-03 15:11:04 EST
Created attachment 276081 [details]
Output from gdb "thread apply all bt" when attached to frozen evolution process

I ran evolution at the command line, turned message preview on, clicked on a
Google Calendar Reminder and evolution hangs.  I then attached gdb to the
frozen evolution process and ran "thread apply all bt" in gdb.
Comment 4 Troy Carter 2007-12-03 15:12:57 EST
Answers to your questions:

(a) see comment #3 above
(b) see comment #2 above
(c) "show image animations" is checked, "prompt when sending html messages..."
is checked, "Always load images from the internet" is checked, under Plain Text,
"Show HTML if present" is checked
(d) I am not using calendars within evolution (so I have not set up any)
Comment 5 Milan Crha 2007-12-03 15:50:13 EST
Thanks for quick reply.

Based on the stack trace, it waits until the default time zone is set for the
calendar. I guess it get stuck, but the CPU usage is low (or at least none of
evolution related processes use it, maybe only evolution-data-server?).

I guess it will work well if you disable Edit->Plugins->Itip Formatter (it get
stuck in this plugin), but that is no solution.

e) Can you look at Edit->Preferences->Calendar and Task, Time zone? What is there?
f) Are you able to open calendar in evolution (View->Window->Calendars)? There
should be On This Computer/Personal, at least. Can you try to add there any
event? And what will change to the email preview if the previous thing will work?

(I just guess the calendar isn't initialized yet, I mean in whole Evolution, as
you mentioned you do not use it, so that can be the reason. But I can be wrong,
so I'm asking. There is a possibility that when you open calendar, then it gets
initialized and it starts to work. Maybe.)
Comment 6 Troy Carter 2007-12-03 17:04:17 EST
(In reply to comment #5)
> Thanks for quick reply.
> 
> Based on the stack trace, it waits until the default time zone is set for the
> calendar. I guess it get stuck, but the CPU usage is low (or at least none of
> evolution related processes use it, maybe only evolution-data-server?).


Yes, there is very little CPU useage

> 
> I guess it will work well if you disable Edit->Plugins->Itip Formatter (it get
> stuck in this plugin), but that is no solution.
> 
> e) Can you look at Edit->Preferences->Calendar and Task, Time zone? What is there?

It is set to the proper time zone, (Los Angeles).

> f) Are you able to open calendar in evolution (View->Window->Calendars)? There
> should be On This Computer/Personal, at least. Can you try to add there any
> event? And what will change to the email preview if the previous thing will work?
> 

This seems to have fixed the problem. I went in and created a calendar item (the
first time I tried it it seemed to hang, but on the second time it took).  After
that, the google message loads properly.  So I suppose it was some sort of
initialization issue with my calendar as you guessed?




Comment 7 Troy Carter 2007-12-03 17:06:21 EST
Something I should have added in the original report: this used to work fine
before I updated to FC8, so whatever problem exists with un-initialized
calendars is new to evolution in FC8.
Comment 8 Milan Crha 2007-12-04 04:48:26 EST
It really seems to be because of uninitialized calendar(s). I will look at it
later. Thanks for your help. Btw, did you updated old Fedora, or made fresh
install and re-setup Evolution?
Comment 9 Troy Carter 2007-12-04 12:07:13 EST
(In reply to comment #8)
> It really seems to be because of uninitialized calendar(s). I will look at it
> later. Thanks for your help. Btw, did you updated old Fedora, or made fresh
> install and re-setup Evolution?

The machine I am currently using came with FC7, I updated to FC8 using yum.  My
user account and config files (on NFS) have been around for a while (since
before FC1), although I recreated my evolution directory not all that long ago
(moved .evolution out of the way and let a new directory be created, maybe <1
year ago).  So there may be some old cruft from long ago in my config files (but
maybe not in .evolution). 

Comment 10 Milan Crha 2008-01-02 11:12:14 EST
Weired. It did the same for me too, in e_cal_set_default_timezone, but only
once. I cannot reproduce it again. I also had calendars initialized (I was in
the calendar component before), so it is not the trouble here. I also looked
into the code and I do not see there any bad thing (I tested also the code a
bit, because I thought about some bug in e_flag_wait function, but I was wrong,
I didn't find it.) I only know that the Evolution is waiting until the operation
is finished, but it is either already finished or something was wrong and the
operation flag wasn't set properly to "done". So I was guessing that the
operation was too quick, but no luck while I tested it. I have no other idea how
to fix this, because without a reproducer, it's hard to say "fixed". Any idea?
Comment 11 Milan Crha 2008-01-17 12:58:26 EST
I will move this to upstream bug [1] which you entered before.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=501298

Note You need to log in before you can comment on or make changes to this bug.