Bug 408981 - xmodmap cannot be used to change the mouse buttons for left handed mouse
xmodmap cannot be used to change the mouse buttons for left handed mouse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
9
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 13:15 EST by dann
Modified: 2008-07-16 20:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 20:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (78.04 KB, text/plain)
2007-12-06 02:06 EST, dann
no flags Details
xorg.conf (1.18 KB, text/plain)
2007-12-06 02:07 EST, dann
no flags Details

  None (edit)
Description dann 2007-12-03 13:15:58 EST
Description of problem:

xmodmap -e "pointer = 3 2 1 4 5 6 7 8 9 10 11 12"

does not work anymore to change the mouse buttons for a left handed mouse.

The command completes without error, and it seems to have worked:

xmodmap -pp

There are 12 pointer buttons defined.

    Physical        Button
     Button          Code
        1              3
        2              2
        3              1
        4              4
        5              5
        6              6
        7              7
        8              8
        9              9
       10             10
       11             11
       12             12

but the button assignment does change in fact. 

This is an up to date F8 Thinkpad T43 machine. It is a fresh install.
The window manager if fvwm. 
I've had FC5 before on the machine and everything worked fine.

Can this be fixed? The mouse is not currently usable...

Version-Release number of selected component (if applicable):

xorg-x11-server-utils-7.3-1.fc8

Thanks!
Comment 1 Matěj Cepl 2007-12-04 17:33:37 EST
Just curious, what kind of mouse have twelve buttons? Anyway, could we please
get /etc/X11/xorg.conf and /var/log/Xorg.0.log as uncompressed separate
attachments to this bug, please?
Comment 2 dann 2007-12-06 02:06:50 EST
Created attachment 279311 [details]
Xorg.0.log
Comment 3 dann 2007-12-06 02:07:38 EST
Created attachment 279331 [details]
xorg.conf
Comment 4 dann 2007-12-06 02:10:11 EST
Things work if I change the mouse settings in xorg.conf to be like the ones I
had on FC5 on the same machine:
(and the mouse now only has 9 buttons)

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Synaptics" "AlwaysCore"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "no"
        Option      "SendCoreEvents" "true"
EndSection
Comment 5 Bug Zapper 2008-05-14 00:04:47 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Peter Hutterer 2008-07-16 20:15:28 EDT
Not sure what the issue was there, but xmodmap definitely works in F9.

Closing as fixed in CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.