This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 409121 - fully kerberize cups (update to 1.3.x)
fully kerberize cups (update to 1.3.x)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.2
All Linux
high Severity medium
: ---
: ---
Assigned To: Tim Waugh
: Rebase
: 445375 (view as bug list)
Depends On: 468729
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2007-12-03 14:02 EST by Kevin Krafthefer
Modified: 2010-10-22 16:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
cups is now re-based to version 1.3.7. This update applies several bug fixes and enhancements, including: * Kerberos authentication is now supported. * User-defined printer and job policies are now loaded correctly. * Remote queue caches are no longer loaded when browsing is disabled. * The classes.conf configuration file now has correct file permissions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:57:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Krafthefer 2007-12-03 14:02:19 EST
Description of problem:
Due to IPA requirements, cups needs to be fully kerberized. For details, please
see Karl Wirth

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2007-12-11 09:06:27 EST
Please put details here.  In particular, CUPS does already have Kerberos support
-- what is missing that is required for IPA?
Comment 2 Karl Wirth 2007-12-11 14:38:45 EST
The IPA team thought that cups was not kerberized in RHEL.  Does this support
ship with RHEL? Has this support been well exercised?
Comment 3 Tim Waugh 2007-12-12 07:44:19 EST
Oh, I was mistaken in comment #1.  In RHEL-5 there is no Kerberos support in
CUPS (1.2.x).  Kerberos support is present in CUPS 1.3.x, available in Fedora 8.
Comment 4 Karl Wirth 2007-12-12 10:36:28 EST
So can we move to CUPS 1.3.x for RHEL 5.2?  That is what this bug request is for.
Comment 5 Tim Waugh 2007-12-12 11:10:28 EST
Usually we back-port changes to the versions originally shipped -- 1.2.4 in this
case.  1.3.x is a new major version and would need a very large amount of
regression testing.

Is that really what we want to do?

(I'm not saying that back-porting the Kerberos support is any less work -- the
changes are quite widespread -- just that it's quite unusual to switch to a new
package version in a supported release.)
Comment 9 Tim Waugh 2008-05-06 17:59:50 EDT
*** Bug 445375 has been marked as a duplicate of this bug. ***
Comment 10 RHEL Product and Program Management 2008-06-02 16:27:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Phil Knirsch 2008-06-13 09:36:21 EDT
This bug needs a review from the component owner before granting Devel ACK.

Thanks,

Read ya, Phil
Comment 16 Tony Fu 2008-10-05 21:48:30 EDT
User krafthef@redhat.com's account has been closed
Comment 19 Don Domingo 2008-11-11 23:16:32 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
cups is now re-based to version 1.3.7. This update applies several bug fixes and enhancements, including:

* Kerberos authentication is now supported.
* User-defined printer and job policies are now loaded correctly.
* Remote queue caches are no longer loaded when browsing is disabled.
* The classes.conf configuration file now has correct file permissions.
Comment 22 errata-xmlrpc 2009-01-20 16:57:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html

Note You need to log in before you can comment on or make changes to this bug.