This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 409191 - Show Repository in Pup Updater
Show Repository in Pup Updater
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 14:53 EST by Patrick Steiner
Modified: 2007-12-04 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 16:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pup Repository Patch (2.46 KB, application/octet-stream)
2007-12-03 18:05 EST, Patrick Steiner
no flags Details
Pup Screenshot (38.02 KB, image/png)
2007-12-03 18:06 EST, Patrick Steiner
no flags Details

  None (edit)
Description Patrick Steiner 2007-12-03 14:53:57 EST
it would be nice if there where a own column in the pup application, where the
selected repository is shown.

so i can see if the local mirror repository is selected.
Comment 1 Patrick Steiner 2007-12-03 18:05:34 EST
Created attachment 276371 [details]
Pup Repository Patch

I have written this this patch, who includes the function. Perhaps someone
could take a look at it and add it to upstream if it is ok.
Comment 2 Patrick Steiner 2007-12-03 18:06:32 EST
Created attachment 276381 [details]
Pup Screenshot

here is a screenshot how it should look like
Comment 3 Jeremy Katz 2007-12-04 16:47:36 EST
The information on where the package comes from isn't that interesting, though,
for most users.  

If you want to prefer your local mirror, you should either set it up so that
your mirror gets returned to you by the mirrorlist or even just set the "cost"
of your local mirror to be lower (see the cost option in man yum.conf)
Comment 4 Patrick Steiner 2007-12-04 17:06:20 EST
i have setup the local mirror via the priority plugin from yum. this works 
fine. but it would be nice if i see where pup loads the rpms. because sometime 
there are different repos with different (incompatible) versions of a rpm. 
like atrpms, livna, freshmeat.... and so it think this would be very 
interesting for the users.

Note You need to log in before you can comment on or make changes to this bug.