Bug 40929 - URW courier: } appears as |
URW courier: } appears as |
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: urw-fonts (Show other bugs)
7.3
noarch Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-16 11:50 EDT by Rex Dieter
Modified: 2006-04-18 09:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 09:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xfs config (1.20 KB, text/plain)
2002-05-28 11:36 EDT, Rex Dieter
no flags Details
XF86Config-4 (1.78 KB, text/plain)
2002-05-28 11:39 EDT, Rex Dieter
no flags Details
rpms.txt (13.29 KB, text/plain)
2002-05-28 11:40 EDT, Rex Dieter
no flags Details
{}| at 10pts (12.83 KB, image/png)
2003-01-22 09:17 EST, Rex Dieter
no flags Details
{}| at 11pt (12.79 KB, image/png)
2003-01-22 09:19 EST, Rex Dieter
no flags Details
{}| at 12pt (12.83 KB, image/png)
2003-01-22 09:21 EST, Rex Dieter
no flags Details
{}| at 13pt (12.83 KB, image/png)
2003-01-22 09:22 EST, Rex Dieter
no flags Details
{}| at 14pt (12.83 KB, image/png)
2003-01-22 09:24 EST, Rex Dieter
no flags Details

  None (edit)
Description Rex Dieter 2001-05-16 11:50:45 EDT
Description of Problem:
In the default KDE environment where the fixed font defaults to Courier, 
it appears to always choose to use URW-Courier (if urw-fonts is 
installed), which in kedit and kwrite, makes } (right curly brace) appear 
as | (verticle bar).  This is on a machine with ATI Rage98 video @ 
1152x864 resolution.  

On the same machine @ 1024x768 resolution, the curly braces almost appear 
correct (with URW-Courier) except only the top 2/3's of the braces 
appear, and the bottom 1/3 are cropped.

Manually choosing adobe-courier (whether as default fixed font in KDE 
control panel or in kedit's preferences) makes things display as expected.

Based on all this, I'm not really sure if this is a KDE, XFree, or 
urw-fonts bug, but it is undesirable behavior, nonetheless.
Comment 1 Ngo Than 2001-07-18 05:15:44 EDT
It's a bug in XFree86 (xfs)
Comment 2 Mike A. Harris 2002-05-22 07:25:45 EDT
Does this problem still occur?
If so, please indicate what Red Hat Linux release you are currently using,
and attach the following output:

1) rpm -qa | sort
2) Your /etc/X11/fs/config
3) Your /etc/X11/XF86Config and /etc/X11/XF86Config-4

Thanks.
Comment 3 Rex Dieter 2002-05-22 10:17:32 EDT
I WAS using stock rh 7.1 (KDE 2.2?, XFree86-4.0.3) when I saw this, but I'm  
using RH 7.3 now, and no longer see the problem.
Comment 4 Rex Dieter 2002-05-22 16:20:24 EDT
 I take it back... I'm still seeing it, but now but ONLY when using URW 
Courier at 10pt on RedHat 7.3, curly braces appear as square braces.  At other 
pt sizes (I tried 8,9,11,12,13,14) curly braces appear correct.  I'll attach 
your request package info and config files shortly.
Comment 5 Rex Dieter 2002-05-28 11:36:53 EDT
Created attachment 58764 [details]
xfs config
Comment 6 Rex Dieter 2002-05-28 11:39:04 EDT
Created attachment 58765 [details]
XF86Config-4
Comment 7 Rex Dieter 2002-05-28 11:40:51 EDT
Created attachment 58766 [details]
rpms.txt
Comment 8 Mike A. Harris 2002-05-30 19:27:04 EDT
I have seen the problem you are describing at some point in time.  I don't have
a clue what font it was, and wasn't sure if it was just my eyes playing tricks
on me or not.  I haven't seen the problem in ages however, and am unable to
reproduce it currently.

I will look deeper into this later on, but I thought I would at least let
you know that it is not a high priority currently.  If you can find a fix
upstream or determine the problem on your own and report back, it could
help speed up the issue.  I recall seeing someone reporting this somewhere
else too, so you might want to inquire on xpert@xfree86.org or query other
bug databases at Debian, Mandrake, etc.. in case someone else has any info
on it.

If I stumble across anything in the mean time, or if I end up reproducing
it somehow, I'll update the report and try to fix it.

Thanks.
Comment 9 Mike A. Harris 2002-06-03 01:44:33 EDT
Can you attach a screenshot showing this using gfontsel to select the font,
and type in {}| into the text entry dialog.  I want to compare it with what
I see.  Include several shots if you like.  Hopefully we can reproduce the
same visual thing.
Comment 10 Mike A. Harris 2002-07-16 05:36:27 EDT
Reassigning to urw-fonts, as I don't see how it can be an XFree86 bug
personally.  The fonts aren't part of XFree86.
Comment 11 Rex Dieter 2003-01-22 09:15:14 EST
Attaching snapshots from gfontsel at 10-14 points showing problems correctly displaying: {}| 
Comment 12 Rex Dieter 2003-01-22 09:17:22 EST
Created attachment 89519 [details]
{}| at 10pts
Comment 13 Rex Dieter 2003-01-22 09:19:34 EST
Created attachment 89520 [details]
{}| at 11pt
Comment 14 Rex Dieter 2003-01-22 09:21:14 EST
Created attachment 89521 [details]
{}| at 12pt
Comment 15 Rex Dieter 2003-01-22 09:23:02 EST
Created attachment 89522 [details]
{}| at 13pt
Comment 16 Rex Dieter 2003-01-22 09:24:26 EST
Created attachment 89523 [details]
{}| at 14pt
Comment 17 Rex Dieter 2006-04-18 09:36:59 EDT
Haven't seen this in ages, closing.

Note You need to log in before you can comment on or make changes to this bug.