Bug 40937 - ld looks for /usrusr
Summary: ld looks for /usrusr
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: binutils   
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-16 18:03 UTC by Peter Bowen
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 00:00:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bowen 2001-05-16 18:03:18 UTC
Description of Problem:

ld, when invoked manually, looks for /usrusr instead of /usr in some cases.
This is due to a long standing bug that the specfile has:

make tooldir=%{_prefix}usr all info

in it.  %{_prefix}usr expands into /usrusr with in incorrect. Instead, 
this should be:

make tooldir=%{_prefix} all info

This bug is found in the current rawhide version of binutils
(2.10.91.0.2-3), and has been an issue since before the version released
with 6.2 (2.9.5.0.22).  6.2, 7.0, and 7.1 all exhibit the problem.

Comment 1 Peter Bowen 2001-08-06 00:01:22 UTC
This appears to have been fixed in Roswell


Note You need to log in before you can comment on or make changes to this bug.