Bug 409381 - fence_scsi: service scsi_reserve restart not present.
fence_scsi: service scsi_reserve restart not present.
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
Depends On:
Blocks: 455330
  Show dependency treegraph
 
Reported: 2007-12-03 16:02 EST by Dean Jansa
Modified: 2009-05-18 17:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2007-12-03 16:02:12 EST
Description of problem:

I attempted to "unfence" a node  by restarting the scsi_reserve service,
however running 'service scsi_reserve restart' did nothing.  I had to 
run 'service scsi_reserve stop && service scsi_reserve start'

Should restart be implemented in the init script?  If we don't support restart
there should be some output saying as much when a user attpemts a restart.

Version-Release number of selected component (if applicable):
fence-1.32.50-2.fencescsi.test.patch
Comment 1 Ryan O'Hara 2007-12-04 00:16:15 EST
You can simply run 'scsi_reserve start', which will register the node with all
relevant devices. If the reservation already exists, it does nothing.

I could implement a 'restart' command if it seems like the right thing to do.
Keep in mind that unlike other services, scsi_reserve is not a long-running
process (daemon).

So would restart actually unregister and re-register the node with all the
devices? Or simply re-run the registration (start)?

Comment 2 Ryan O'Hara 2008-09-05 17:47:34 EDT
Fixed in RHEL4.

The fix for this is not truly a restart, but I don't think that is
what we want for this particular script.

In my opinion, a *true* restart would be to remove (unregister) our key from
all devices and the re-register our key with all devices. We want to avoid
removing the key. As soon as the key is remove, the node has no write access to
the disk(s). For fencing via SCSI-3 reservations, this is as good as being
fenced. Its best that we avoid removing keys from the devices.

The way I have "restart" implemented now is to do almost exactly what "start"
does. If the script is called with the "restart" option, we simply get a list
of all devices within cluster volumes and register our key with those devices.
It does not matter if our node/key is already registered because of the way we
create the registration. Then we check to see if a reservation exist for the
device, and if not, we create the reservation.
Comment 5 errata-xmlrpc 2009-05-18 17:16:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1050.html

Note You need to log in before you can comment on or make changes to this bug.