Bug 409391 - fence_scsi: Error message vauge, supply more info to user.
fence_scsi: Error message vauge, supply more info to user.
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 16:08 EST by Dean Jansa
Modified: 2009-04-16 16:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0801
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2007-12-03 16:08:30 EST
Description of problem:

I attempted to fence a node via fence_scsi and got "No such file or directory."
Perplexed I looked at the code and found it was looking for
/var/run/scsi_reserve, which was not found on taft-04.  Adding a bit more info
to the error message would be useful.

[root@taft-04 ~]# fence_scsi -n taft-03
No such file or directory


Version-Release number of selected component (if applicable):
fence-1.32.50-2.fencescsi.test.patch



Additional info:
Comment 1 Ryan O'Hara 2007-12-04 00:19:34 EST
This should be fixed in my next set of changes. I'm removing the use of the
/var/run/scsi_reserve file. That file is keeps a list of devices the node
registered with, which is used as fence time. The fence_scsi script should get a
list of devices from 'lvs' (as done in scsi_reserve) rather than depend on this
file.
Comment 2 Ryan O'Hara 2008-04-04 18:59:02 EDT
Fixed. RHEL4 will no longer be using the state file (/var/run/scsi_reserve) for
tracking registered devices. Instead, script use vgs command with locking_type=0
option such that we can get list of devices on-the-fly, even at fence time.

The fence_scsi and scsi_reserve scripts should be mostly identical between RHEL4
and RHEL5 now.

Also note that the experimental scsi_watchdog code was removed as a result of
this fix, since it depended on this state file.

Comment 4 RHEL Product and Program Management 2008-04-07 15:38:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2008-07-25 15:16:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0801.html

Note You need to log in before you can comment on or make changes to this bug.