Bug 40970 - NFS locking fails
Summary: NFS locking fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-16 20:03 UTC by Piotr Parlewicz
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 21:45:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Piotr Parlewicz 2001-05-16 20:03:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I am using nfs-utils-0.3.1-5 on the NFS server (Linux). The client is
an HPUX 11 HP 9000/785. I get a 'No locks available' error on the client. 
The server logs a : "kernel: nfsd: request from insecure port 
(5900fee9:49437)!" in the messages file, even thought the exports file on 
the server specifies : 
"/home 89.0.254.233(rw,no_root_squash,insecure)"


How reproducible:
Always

Steps to Reproduce:
1.share a directory from Linux 7.1
2.mount the share from HPUX 11
3.write a short program that uses fcntl to lock a file on the NFS share
	

Actual Results:  fcntl() returns -1, perror() prints "No locks available" 

Expected Results:  Lock should have been aquired. When the client is a 
Solaris box
this works fine. When the HP-UX connects to an NFS share on the 
Solaris box this work fine. Only client HP , server Linux seems to
fail.

Additional info:

nfsd and lockd are loadable modules, /etc/init.d/nfs start , and
/etc/init.d/nfslock were run

Comment 1 Bob Matthews 2001-05-16 21:43:08 UTC
Sounds like lockd is dying on the server.  Can you see the lockd process on the
server after the failure?  

There is a later nfs-utils available (0.3.1-8).  Can you try that?

Also, lockd is start automagically in the kernel in kernels 2.2.18+, so you
should need to run the lockd init script if you're running a recent enough
kernel.



Comment 2 Bob Matthews 2001-05-16 21:44:55 UTC
> ...so you should need to...

Sorry, read "...so you shouldn't need to..."

Comment 3 Piotr Parlewicz 2001-05-17 15:42:38 UTC
OK, problem solved. After some time went by, (about 2 hours), I tried
it again, and this time it worked. Looks like the lockd servers
needed some time to get their act together.
In retrospect I believe the bug originated from trying to use
NFS locking, without starting the '/etc/init.d/nfslock start'
server. The loadable kernel modules (nfs and lockd) were allways
present, but I guess starting it this way does something good for it.




Note You need to log in before you can comment on or make changes to this bug.