Bug 40972 - msgmerge corrupts input strings in korean and japanese po files
Summary: msgmerge corrupts input strings in korean and japanese po files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gettext   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-16 20:13 UTC by Håvard Kvålen
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 20:21:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Håvard Kvålen 2001-05-16 20:13:19 UTC
msgmerge destroys some input strings in japanese and korean .po files.

A way to reproduce this, is to create this string in an input file: "i". 
In my case the input files are in ISO-8859-1.  After running msgmerge all
po files get updated ok, unless ko.po and ja.po where this string gets
changed to: "i\0" where the "0" is a zero byte (\0).

The problem seems to be this patch:
gettext-0.10.35-oka-plus.patch

$ rpm -q gettext
gettext-0.10.35-31

Comment 1 Trond Eivind Glomsrxd 2001-05-16 20:17:52 UTC
Do you have any specific examples?

Nakai, this is the patch you added to make it handle Japanese properly... could
you look into this?

Comment 2 Håvard Kvålen 2001-05-16 20:21:19 UTC
That input string were supposed to consist of the letter "e with acute" (0xe9)

Comment 3 Trond Eivind Glomsrxd 2001-06-04 14:04:11 UTC
Nakai believes this no longer to be a problem with gettext 0.10.37 and above,
currently in Rawhide. Open if this is still a problem.


Note You need to log in before you can comment on or make changes to this bug.