Bug 410071 - USB serial port adapter not detected at boot time
USB serial port adapter not detected at boot time
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 05:57 EST by Paul Osmialowski
Modified: 2008-01-05 05:47 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 05:47:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Osmialowski 2007-12-04 05:57:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.0.12) Gecko/20071019 Fedora/1.5.0.12-5.fc6 Firefox/1.5.0.12

Description of problem:
I've just installed F8 on PowerBook G4 equipped with USB webcam and USB serial adapter. Both these devices are attached all the time, however only USB webcam operated by sn9c102 kernel module is detected at boot time (so /dev/video0 is present and is usable). Unfortunately, USB serial adapter is unusable until I unplug it and plug again. At that time, pl2303 kernel module is loaded (which leads to load usbserial module also) and /dev/ttyUSB0 is created and is usable. My problem is that I'm using this host remotely and ability to perform reboot remotely is somewhat critical for me. Also, serial device that I'm using with it is also critical for me (a kind of "remote presence" stuff). I've tried to modprobe pl2303 module into kernel right after reboot, but it does not lead to /dev/ttyUSB0 to be created (however, usbserial module is listed by lsmod). I've tried to create it using mknod, but it didn't help: device is still unaccessible. The only way to make it work is to unplug it and plug in again. How come there's no such problem with cheapest USB webcam I could buy?!
The problem shows up no matter if I reboot the host or halt whole machine and turn it on again.


Version-Release number of selected component (if applicable):
kudzu-1.2.79.1-1 kernel-2.6.23.1-49.fc8

How reproducible:
Always


Steps to Reproduce:
1. Connect serial adapter to USB socket
2. Turn on the computer and boot Fedora 8
3. Try to use /dev/ttyUSB0 (use minicom for example)

Actual Results:
there's no /dev/ttyUSB0, it only appears when you unplug serial adapter and plug it in again

Expected Results:
USB serial adapter should be discovered at boot time and /dev/ttyUSB0 should be created in /dev tree.


Additional info:
Comment 1 Paul Osmialowski 2008-01-05 05:47:35 EST
Later I've discovered that I have this problem with all USB devices that I'm
connecting to this (second one) USB port on my G4. Finally I've connected USB
Hub to (the first one) USB port and all devices (camera, serial adapter,
ethernet adapter) are discovered at boot time properly. However whole story seem
to be strange for me and I'll reopen this topic if I find more problems with USB
on G4.

Note You need to log in before you can comment on or make changes to this bug.