Bug 410291 - strange behavior with dogtail.rawinput.pressKey()
strange behavior with dogtail.rawinput.pressKey()
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 08:04 EST by Alexander Todorov
Modified: 2009-01-09 00:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:25:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virsh dumpxml output (1.03 KB, text/plain)
2007-12-18 04:23 EST, Alexander Todorov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 508147 None None None Never

  None (edit)
Description Alexander Todorov 2007-12-04 08:04:30 EST
Description of problem:
Originaly filed as:
http://bugzilla.gnome.org/show_bug.cgi?id=501286
The VNC viewer used to show a xen guest's console doesn't handle AT-SPI events
correctly.

Version-Release number of selected component (if applicable):
virt-viewer-0.0.2-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Use virt-install to start a Xen HVM (para virt should do as well) installation
2. Wait for the VNC console to appear
3. start python
3. use dogtail.rawinput.pressKey(':') which sould generate a key press event at
the VNC console
4. instead of colon ':' there appears a semi-colon ';'
  
Actual results:
VNC widget shows a semi-colon instead of colon

Expected results:
VNC widget shows the exact same characters as dogtail.rawinput instructs it to show.

Additional info:
Same behavior occurs with Fedora8/virt-viewer(GTK VNC widget) and
RHEL5/vncviewer(vnc package).
Comment 1 Alexander Todorov 2007-12-04 08:06:52 EST
I am still not sure if the bug is in the viewer or the underlying GTK/VNC widget.
Comment 2 Michal Babej 2007-12-17 07:52:58 EST
Xorg + vnc extension works for me. So i think this is vnc related issue.
Comment 3 Daniel Berrange 2007-12-17 09:05:20 EST
Can you tell me what keymap you have configured on your local X desktop, what
keymap is configured inside the guest OS, and include the output of 'virsh
dumpxml [name of guest]' for the guest that you are trying to view.
Comment 4 Alexander Todorov 2007-12-18 04:23:33 EST
Created attachment 289867 [details]
virsh dumpxml output

> keymap configured inside the guest OS
I'm not sure how do I tell. I hit the bug when booting the installation media.

> keymap configured on your local X desktop
Same here. I don't remember doing some speciffic settings in my GNOME session. 

Which file should I look for that?

Additional info:
I've tried both when running GNOME and when running Xvnc without anything else
started. Hit the bug both times.
Comment 5 Michal Babej 2008-01-08 08:12:41 EST
moving to at-spi component, since i'm pretty sure it's a bug in at-spi-registryd.

VNC server doesn't support XKB extension, and
at-spi-1.18.1/registryd/deviceeventcontroller.c 
contains this piece of code:


static gboolean
dec_lock_modifiers (SpiDEController *controller, unsigned modifiers)
{
        return XkbLockModifiers (spi_get_display (), XkbUseCoreKbd, 
                          modifiers, modifiers);
}


So locking any modifier keys doesn't work through VNC.
Comment 6 Michal Babej 2008-01-10 10:10:54 EST
provided a patch in the upstream bug, needs review though.
Comment 7 Alexander Todorov 2008-01-10 11:05:22 EST
Michal provided custom build rpms for RHEL 5.1 and I verified that his patches work.
Comment 8 Bug Zapper 2008-11-26 03:49:37 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-01-09 00:25:17 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.