Bug 410411 - NFS v.4 not available in diskless machines
NFS v.4 not available in diskless machines
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 09:01 EST by Ondrej Valousek
Modified: 2008-07-24 15:33 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0672
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (674 bytes, patch)
2008-01-07 08:18 EST, Radek Brich
no flags Details | Diff
new patch (592 bytes, patch)
2008-01-31 10:48 EST, Radek Brich
no flags Details | Diff

  None (edit)
Description Ondrej Valousek 2007-12-04 09:01:13 EST
Description of problem:
/var/lib/nfs/rpc_pipefs/ filesystem is not properly mounted in diskless machines.
Compare normal machine (booting from HDD):
/var/lib/nfs/rpc_pipefs/ directory is mounted via the sunrpc kernel module
Diskless machine (booting from net):
/var/lib/nfs/rpc_pipefs/ is mounted on NFS server, snapshot directory

Version-Release number of selected component (if applicable):
system-config-netboot-0.1.40-1_EL4

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
/var/lib/nfs/rpc_pipefs should be always mounted via sunrpc kernel module,
otherwise NFSv4 functionality (idmapd) is broken.

Additional info:
Comment 1 Ondrej Valousek 2007-12-05 13:14:24 EST
As I stated before, I am stuck to the oficial system-config-netboot version
0.1.40 so I can not if this was not fixed in the latest version.
If not, the quick fix (or workaround) is to add the following:
sunrpc          /var/lib/nfs/rpc_pipefs         rpc_pipefs      defaults        0 0
in /etc/fstab for the diskless machines. I do not think it is the most "elegant"
solution though...
Comment 2 Radek Brich 2008-01-07 08:15:51 EST
I think it should be mounted by modprobe rules, but this does not seem to work,
even if /var/lib/nfs/rpc_pipefs is empty.

Adding proper mount command to disklessrc works fine.
Comment 3 Radek Brich 2008-01-07 08:18:26 EST
Created attachment 290950 [details]
proposed patch
Comment 4 RHEL Product and Program Management 2008-01-07 08:36:55 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Radek Brich 2008-01-31 10:48:20 EST
Created attachment 293593 [details]
new patch

New patch without unnecessary lines.

The explicit mount command is needed because NFS modules are loaded too early,
even before the mount point (/var/lib/nfs/rpc_pipefs) is available. The normal
mount thus fails.
Comment 11 errata-xmlrpc 2008-07-24 15:33:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0672.html

Note You need to log in before you can comment on or make changes to this bug.