Bug 41050 - request for /etc/sysconfig/dhcpd
request for /etc/sysconfig/dhcpd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-16 23:35 EDT by Ian Mortimer
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add sysconfig configuration to dhcpd startup (1.06 KB, patch)
2001-05-16 23:38 EDT, Ian Mortimer
no flags Details | Diff

  None (edit)
Description Ian Mortimer 2001-05-16 23:35:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
dhcpd can take a number of command line options the most useful of which is
the interface you want it to listen on.  At  present the only way to
specify any options is to edit /etc/init.d/dhcpd which is not desirable. 

The patch included modifies /etc/init.d/dhcpd to source
/etc/sysconfig/dhcpd and set command line arguments accordingly.  Also
included is a sample dhcpd sysconfig file.

How reproducible:
Always

Steps to Reproduce:
1. Not applicable
2.
3.
	

Additional info:
Comment 1 Ian Mortimer 2001-05-16 23:38:28 EDT
Created attachment 18710 [details]
Patch to add sysconfig configuration to dhcpd startup
Comment 2 Ian Mortimer 2001-05-16 23:46:25 EDT
Bugzilla didn't let me add the second attachment which was supposed to be the
example sysconfig file.  Here it is (entries should be self explanatory):

#PORT=67
#CFFILE=/etc/dhcpd.conf
#LEASEFILE=/var/lib/dhcp/dhcpd.leases
#QUIET=NO
#INTERFACES=''
INTERFACES='eth1'
Comment 3 Mike Chambers 2001-06-27 07:33:32 EDT
Shouldn't the install of dhcp also include a dhcp.conf file in /etc 
or /etc/dhcp/?  What happens if you upgrade does it keep the current?  Wouldn't 
it also need to add the default as .rpmnew or .rpmsave but do it in one of the 
above directories or in a nice easy location instead of hunting it down and 
having to edit /etc/init.d/dhcpd to reflect that?

I haven't used it myself but always asked where it is but could never find it.
Comment 4 Michael Schwendt 2001-06-27 08:01:48 EDT
Reporter: One way to add another attachment is to GO BACK to the bug page. Right
above the comments field is the 'Attachments' menu.
Comment 5 Mikkel L. Ellertson 2001-06-27 10:45:52 EDT
It would be nice if, as part of the post install script, the RPM would touch the
dhcpd.leases file, so that if there isn't one, it will be created.  The
documentation with the package does not indicate that you have to create the
file, and if you are upgrading from an older version, the location changed.  So
you can go from a working dhcpd setup to a broken setup  by doing an upgrade. 
The same /etc/dhcpd.conf file will work.
Comment 6 Elliot Lee 2001-12-28 13:50:35 EST
The dhcp-3.0-2 package in rawhide (and in fact earlier dhcp packages) allow you
to specify DHCPDARGS=... in /etc/sysconfig/dhcpd, so you can pass as many args
as you like without having to add support for them to the initscript. I think
this meets your requirement....

There is no /etc/dhcp.conf by default because configuration is absolutely
required for the daemon to be of any use.

Note You need to log in before you can comment on or make changes to this bug.