Bug 41054 - rpm won't install. Rebuilt database hangs
Summary: rpm won't install. Rebuilt database hangs
Status: CLOSED DUPLICATE of bug 38454
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 06:12 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-22 18:47:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ZIP file of /var/lib/rpm (8.67 MB, application/octet-stream)
2001-05-17 06:27 UTC, Need Real Name
no flags Details
tar czvf /tmp/rpmdb.tar.gz rpmr -- after cd /var/lib -- tnx de N6JNU (deleted)
2001-05-22 03:57 UTC, Need Real Name
no flags Details
created with tar czvf /tmp/rpmdb.tar.gz rpm -- tnx de N6JNU (deleted)
2001-05-22 04:14 UTC, Need Real Name
no flags Details
I am E-mailing this also (deleted)
2001-05-23 03:20 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-05-17 06:12:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Failed rpm installation of staroffice.  After this, could not run up2date
or install
rpms manually with rpm -i.
Attempted rpm --rebuilddb  which almost works, but hangs before finishing

How reproducible:
Always

Steps to Reproduce:
1. rpm -rebuilddb -vv  (the -vv to watch progress)
2.---or rpm -i  --- causes segmentation fault
3.
	

Actual Results:  The end of the rebuild db -vv looks like
this----------------


D: adding "wmakerconf" to Name index.
D: adding 57 entries to Basenames index.
D: adding "User Interface/Desktops" to Group index.
D: adding 29 entries to Requirename index.
D: adding 1 entries to Providename index.
D:   +++        812 xfig-3.2.3c-8
D: adding "xfig" to Name index.
D: adding 824 entries to Basenames index.
D: adding "Applications/Multimedia" to Group index.
D: adding 24 entries to Requirename index.
D: adding 1 entries to Providename index.
D:   +++        813 XFree86-ISO8859-7-75dpi-fonts-1.0-9
D: adding "XFree86-ISO8859-7-75dpi-fonts" to Name index.
D: adding 109 entries to Basenames index.
D: adding "User Interface/X" to Group index.
D: adding 6 entries to Requirename index.
D: adding 1 entries to Providename index.
D:   +++        814 XFree86-Xvfb-4.0.3-5
D: adding "XFree86-Xvfb" to Name index.
D: adding 2 entries to Basenames index.
D: adding "User Interface/X Hardware Support" to Group index.
D: adding 15 entries to Requirename index.
D: adding 1 entries to Providename index.
D:   +++        815 xsysinfo-1.7-3


D: adding "xsysinfo" to Name index.
D: adding 5 entries to Basenames index.
D: adding "Applications/System" to Group index.
D: adding 14 entries to Requirename index.
D: adding 1 entries to Providename index.

Expected Results:  up2date and rpm -i previously worked.

Additional info:

This sounds like other database problems as described by Jeff Jones.
Can you help?

Comment 1 Need Real Name 2001-05-17 06:27:36 UTC
Created attachment 18730 [details]
ZIP file of /var/lib/rpm

Comment 2 Jeff Johnson 2001-05-21 12:56:30 UTC
The zip file is unreadable. Can you add a pointer to a tar.gz file of you
database
please?
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm

Comment 3 Need Real Name 2001-05-22 17:48:27 UTC
I have attached the file that you wanted.



Comment 4 Jeff Johnson 2001-05-22 18:47:52 UTC
Hmmm, still no success success saving the attachments. How about mailing the
tarball to <jbj@redhat.com>? Thanks.

Comment 5 Jeff Johnson 2001-05-23 17:06:42 UTC
Similar problem to #38454, ...

*** This bug has been marked as a duplicate of 38454 ***


Note You need to log in before you can comment on or make changes to this bug.