Bug 410671 - keyboard mouse emulation doesn't survive hibernation
keyboard mouse emulation doesn't survive hibernation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xfwm4 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 11:48 EST by Matthew Miller
Modified: 2008-02-20 22:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 22:22:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-12-04 11:48:45 EST
Description of problem:

When my laptop hibernates, keyboard-based mouse emulation stops working. If I go
to the dialog box and turn it off and back on again, it works again.


Version-Release number of selected component (if applicable):

Happens in Rawhide, F8, and to my knowledge everything before that. I filed this
under xfwm4 but some other component of X or xfce may be to blame.

How reproducible:

Always

Steps to Reproduce:
1. Go to Settings -> Mouse Preferences.
2. In the Accessibility tab, check "Enable Mouse Emulation"
3. Enjoy your emulated mouse.
4. pm-hibernate
5. Resume.

  
Actual results:

Keyboard control of mouse no longer works. If one goes back to the dialog,
Enable Mouse Emulation is still checked. Unchecking it and re-checking
reactivates the feature.

Expected results:

Should just work.
Comment 1 Kevin Fenzi 2007-12-05 14:09:35 EST
Interesting. ;( 

I will try and duplicate this here and see what I can come up with...

The mouse settings applet is in the xfce-mcs-plugins package, but 
it's not clear if it's a setting problem or something deeper. 

Do you get any messages in your ~/.xsession-errors file?
Comment 2 Kevin Fenzi 2007-12-13 00:43:04 EST
Have you had a chance to look at the ~/.xsession-errors file?

Also, 4.4.2 should be out in rawhide now, can you upgrade and see if the problem
persists?
Comment 3 Kevin Fenzi 2008-01-16 01:31:10 EST
Any further news here? I can't duplicate this problem here... 
Comment 4 Kevin Fenzi 2008-02-20 22:22:42 EST
I can't reproduce this. 

I am going to go ahead and close this now, but if you still see the issue, and
can provide further info, feel free to re-open it or file a new bug. 
Comment 5 Matthew Miller 2008-02-20 22:32:29 EST
Sorry, I missed your previous messages. Nothing relevant in ~/.xsession-errors;
it just doesn't work. I'll leave this closed for now (although, in the future I
suggest WORKSFORME rather than NOTABUG in such cases) and test again once I can
reinstall the system with the final F9.
Comment 6 Kevin Fenzi 2008-02-20 22:37:33 EST
Sorry, I can dig more if you like... happy to try and track it down. 

Or perhaps it would be better filed as a upstream bug (which I can do if you
like, or leave to you.) 

Thoughts? 
Comment 7 Matthew Miller 2008-02-20 22:41:31 EST
If you can file it upstream that'd be great. Thanks.
Comment 8 Kevin Fenzi 2008-02-20 22:49:34 EST
http://bugzilla.xfce.org/show_bug.cgi?id=3860

I can't add you to CC there unless you have an account in the Xfce bugzilla. ;( 

Would you like me to reopen this bug and report back when I hear from upstream? 
Or just add a comment when upstream needs more info, etc? 
Comment 9 Matthew Miller 2008-02-20 22:54:50 EST
I have an account there now -- I'll add myself to the CC list and add further
info as I have it. Thanks.

Note You need to log in before you can comment on or make changes to this bug.