Bug 41069 - Missing /usr/include/gtk directory
Summary: Missing /usr/include/gtk directory
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk+   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Mason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 06:39 UTC by Joachim Backes
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 07:00:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Backes 2001-05-17 06:39:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4 i686)

Description of problem:
HAving problems to compile gtk applications: in /usr/include, there is only
a directory gtk-1.2, which has gtk as subdirectory. Therefore, I have
problems to install gtk apps because they standardly use

	#include <gtk/gtk.h>

which fails.

Making a softlink /usr/include/gtk -> /usr/include/gtk-1.2/gtk

would solve the problem.

How reproducible:
Always

Steps to Reproduce:
1. Try to compile a C source having a line with "#include <gtk/gtk.h>
2.
3.
	

Actual Results:  Compile errors

Expected Results:  No compile errors

Additional info:

Workaround: see above

Comment 1 Joachim Backes 2001-05-17 06:49:16 UTC
Having similar problems with #include <glib.h>, because glib.h is in
/usr/include/glib-1.2 and not in /usr/include.


Note You need to log in before you can comment on or make changes to this bug.