Bug 410851 - taxipilot: drop BR: kdemultimedia3-devel
taxipilot: drop BR: kdemultimedia3-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: taxipilot (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 14:16 EST by Rex Dieter
Modified: 2007-12-19 07:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 07:49:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
remove kdemultimedia build dep (1.30 KB, patch)
2007-12-04 14:16 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2007-12-04 14:16:59 EST
Just a heads-up since kdemultimedia will be replaced by it's kde4 counterpart
soon.  We will likely keep some sort of compat kdemultimedia3 pkg around, I'd
rather pkg's not depend on it unless absolutely necessary.

Looks like this BR can be dropped with only minimal patching (sample patch
attached).
Comment 1 Rex Dieter 2007-12-04 14:16:59 EST
Created attachment 277261 [details]
remove kdemultimedia build dep
Comment 2 Hans de Goede 2007-12-11 05:41:00 EST
Hi,

sorry for not getting around to this sooner, but I've been distracted lately
working on other really cool stuff, see:
http://hansdegoede.livejournal.com/

However today I got this mail resulting in my attention being focussed on this
again:

---

taxipilot has broken dependencies in the development tree:
On ppc:
	taxipilot - 0.9.2-4.fc9.ppc requires libartsmodulessynth.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsgui_kde.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsmodules.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsmoduleseffects.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsmidi_idl.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsmodulesmixers.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsbuilder.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsgui_idl.so.0
	taxipilot - 0.9.2-4.fc9.ppc requires libartsmodulescommon.so.0

---

Etc. however I'm afraid that things aren't as easy as applying your patch.
Indeed the taxipilot binary itself doesn't need -lartsmodules -lsoundserver_idl
-lmcop_mt, actually your patch mirrors one already in the taxipilot which
resolves a number of unresolved non weak symbol warnings in the included
libEXT_wavpo.so file:

--- taxipilot-0.9.2/taxipilot/EXT_wavpo/Makefile.in.weaksym     2007-05-28 13:1
+++ taxipilot-0.9.2/taxipilot/EXT_wavpo/Makefile.in     2007-06-03 17:19:34.000
@@ -325,7 +325,7 @@
 ####### kdevelop will overwrite this part!!! (begin)##########
 lib_LTLIBRARIES = libEXT_wavpo.la
 INCLUDES = $(all_includes)
-libEXT_wavpo_la_LDFLAGS = -version-info 0:0:0
+libEXT_wavpo_la_LDFLAGS = -version-info 0:0:0 -lsoundserver_idl -lartsflow
 #>- libEXT_wavpo_la_METASOURCES = AUTO
 libEXT_wavpo_la_SOURCES = ext_wav_play_object_impl.cpp ext_wav_play_object.cc
 EXTRA_DIST = ext_wav_play_object.cc ext_wav_play_object.h ext_wav_play_object.

---

So you see its not the taxipilot binary itself which needs -lartsmodules
-lsoundserver_idl -lmcop_mt, but the included libEXT_wavpo.so file which
taxipilot uses. I know its strange an application shipping part of private code
as a .so file, but thats how upstream has created it.

So what now?
Comment 3 Kevin Kofler 2007-12-15 08:15:52 EST
The reason the code is in a .so file is because it isn't called directly by 
taxipilot, instead taxipilot calls aRts and asks it to use the aRts plugin it 
installs, aRts then dlopens the plugin.

I think we may need a kdemultimedia3 compat package. :-( I also think there 
might be other applications which expect the aRts plugins provided by 
kdemultimedia3 to be there, even if they don't link them explicitly (and thus 
don't show up in the broken deps report), given that aRts plugins are dlopened 
at runtime.
Comment 4 Kevin Kofler 2007-12-18 12:26:47 EST
Uh, the -lsoundserver_idl -lartsflow libraries you're linking to in your 
taxipilot-0.9.1-weaksym.patch are actually in arts-devel, not 
kdemultimedia3-devel. So are you really SURE Rex's patch to remove the 
kdemultimedia3 BRs is not enough?
Comment 5 Hans de Goede 2007-12-19 07:49:09 EST
(In reply to comment #4)
> Uh, the -lsoundserver_idl -lartsflow libraries you're linking to in your 
> taxipilot-0.9.1-weaksym.patch are actually in arts-devel, not 
> kdemultimedia3-devel. So are you really SURE Rex's patch to remove the 
> kdemultimedia3 BRs is not enough?

Ah, your right! A fixed version is on its way to rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.