Bug 41089 - RPM seg fault
RPM seg fault
Status: CLOSED DUPLICATE of bug 36641
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-17 08:15 EDT by Paul Johnson
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 11:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Paul JOhnson's rpm database, as Jeff Johnson asked (deleted)
2001-05-17 08:20 EDT, Paul Johnson
no flags Details

  None (edit)
Description Paul Johnson 2001-05-17 08:15:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
RPM mysteriously started seg faulting. 

[pauljohn@dv209s44 SPECS]$ rpm -ba swarm-hdf5-jdk-RH7-2.1.69.spec
--target=i686 &> buildswarm69.txt
Segmentation fault (core dumped)
[pauljohn@dv209s44 SPECS]$ rpm -ba swarm-hdf5-jdk-RH7-2.1.69.spec
--target=i686      
Building target platforms: i686
Building for target i686
Segmentation fault (core dumped)
[pauljohn@dv209s44 SPECS]$ rpm -ba
swarm-hdf5-jdk-RH7-2.1.69.spec               
Segmentation fault (core dumped)


How reproducible:
Always

Steps to Reproduce:
1. I had this same seg fault problem on a RedHat 7.0 system, and because of
it I installed RH 7.1 in a clean partition.
2. RPM worked fine, I thought I had escaped the problem.
3. After about one month, how RH 7.1 has the same problem.

In the RPM list, Jeff Johnson said "post a bugzilla report and I'll figure
it out.  Well, here it is!"
	

Actual Results:  RPM doesn't work anymore

Expected Results:  ?

Additional info:

I can submit the rpm database in an attachment
Comment 1 Paul Johnson 2001-05-17 08:33:39 EDT
I tried to attach the rpm database, but got a cgi error from the server:Software
error:

DBD::Oracle::st execute failed: ORA-01691: unable to extend lob segment
BUGZILLA.SYS_LOB0000003839C00008$$ by 715 in tablespace ENG_DATA02 (DBD ERROR:
OCILobTrim/OCILobWrite/LOB refetch) at
/mnt/raid0/bugzilla/bugzilla/createattachment.cgi
line 124. 

So I've taken the RPM data and put it on my web page

http://lark.cc.ukans.edu/~pauljohn/linux/rpmdb.tar.gz

Comment 2 Jeff Johnson 2001-05-20 09:37:57 EDT
This is a build problem, you can disable rpmdb access during
build by adding --nodeps.

Can you send a pointer to the src rpm you are building so I can
try to reproduce?
Comment 3 Paul Johnson 2001-05-20 11:19:41 EDT
Dear Jeff:

I can't build the srpm, but I did package the source code, icon, and spec file
and put them here for you to see:

http://lark.cc.ukans.edu/~pauljohn/Swarm/Swarm-2.x_RPMSforRH7/swarm-2.1.69.tar.gz


I tried building with --nodeps. Got no progress.

$ rpm -ba swarm-hdf5-jdk-RH7-2.1.69.spec --target=i686 --nodeps
Building target platforms: i686
Building for target i686
Segmentation fault (core dumped)

After all this, I find RPM can still do a --rebuild without any errors and rpm
-qa still seems to work fine.  I have installed one RPM package from somebody
else and that was OK too.
Comment 4 Jeff Johnson 2001-05-20 13:14:48 EDT
OK, I've reproduced the segfault, same problem as bugzilla #36641. AFAIK, the
problem is fixed in rpm-4.0.3-0.6, availiable at
ftp://ftp.rpm.org/pub/rpm/test-4.0.3
probably through Raw Hide as well.

*** This bug has been marked as a duplicate of 36641 ***

Note You need to log in before you can comment on or make changes to this bug.